<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png">
		<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times RSS Feed" href="https://theblackwallsttimes.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="The Black Wall Street Times Atom Feed" href="https://theblackwallsttimes.com/feed/atom/" />
	<link rel="pingback" href="https://theblackwallsttimes.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://theblackwallsttimes.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	<link rel='preconnect' href='https://fonts.googleapis.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<meta http-equiv='x-dns-prefetch-control' content='on'>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='preload' as='image' href='https://theblackwallsttimes.com/wp-content/uploads/2022/03/THE-BLACK-WALL-STREET-TIMES.jpg' type='image/jpg'>
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/icomoon.woff' type='font/woff' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/weathericons.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/plugins/penci-recipe/fonts/ficon.woff2' type='image/woff2' crossorigin='anonymous'>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Merriweather:r:latin,latin-ext","Merriweather:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://theblackwallsttimes.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css"></style>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO Premium plugin v18.1 (Yoast SEO v18.4.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>&quot;Forgive all student loan debt,&quot; says former Obama Sec. of Education</title>
	<meta name="description" content="Forgiving student loan debt would boost our national post-pandemic economy according to former Obama Sec. of Education John King." />
	<link rel="canonical" href="https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Forgive all student loan debt says former Obama Sec. of Education" />
	<meta property="og:description" content="King, who served under President Barack Obama, told CBS News that the federal government paid roughly 80% of the cost of college for students through its Pell grant program in the 1980s." />
	<meta property="og:url" content="https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/" />
	<meta property="og:site_name" content="The Black Wall Street Times" />
	<meta property="article:publisher" content="https://www.facebook.com/BWSTimes" />
	<meta property="article:published_time" content="2022-03-23T14:10:33+00:00" />
	<meta property="og:image" content="https://theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg" />
	<meta property="og:image:width" content="2048" />
	<meta property="og:image:height" content="1365" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Forgive all student loan debt says former Obama Sec. of Education" />
	<meta name="twitter:description" content="King, who served under President Barack Obama, told CBS News that the federal government paid roughly 80% of the cost of college for students through its Pell grant program in the 1980s." />
	<meta name="twitter:image" content="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&amp;ssl=1" />
	<meta name="twitter:creator" content="@zekethescribe" />
	<meta name="twitter:site" content="@TheBWSTimes" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Ezekiel J. Walker" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://theblackwallsttimes.com/#website","url":"https://theblackwallsttimes.com/","name":"The Black Wall Street Times","description":"Access is the New Civil Right","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://theblackwallsttimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&ssl=1","contentUrl":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&ssl=1","width":2048,"height":1365,"caption":"John King, former Secretary of Education under President Obama. (Education Trust)"},{"@type":"WebPage","@id":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#webpage","url":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/","name":"\"Forgive all student loan debt,\" says former Obama Sec. of Education","isPartOf":{"@id":"https://theblackwallsttimes.com/#website"},"primaryImageOfPage":{"@id":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#primaryimage"},"datePublished":"2022-03-23T14:10:33+00:00","dateModified":"2022-03-23T14:10:33+00:00","author":{"@id":"https://theblackwallsttimes.com/#/schema/person/314456efbab02d61ee586cb25f32ee14"},"description":"Forgiving student loan debt would boost our national post-pandemic economy according to former Obama Sec. of Education John King.","breadcrumb":{"@id":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/"]}]},{"@type":"BreadcrumbList","@id":"https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://theblackwallsttimes.com/"},{"@type":"ListItem","position":2,"name":"&#8220;Forgive all student loan debt,&#8221; says former Obama Sec. of Education"}]},{"@type":"Person","@id":"https://theblackwallsttimes.com/#/schema/person/314456efbab02d61ee586cb25f32ee14","name":"Ezekiel J. Walker","image":{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=96&d=identicon&r=g","caption":"Ezekiel J. Walker"},"description":"Hailing from Charlotte North Carolina, born litterateur and movie junky Ezekiel J. Walker has been writing since forever ago. Shortly after earning a B.A. in Psychology at Winston Salem State University, Walker released his first creative nonfiction book and has gone on to author two subsequent books related to African American culture. Walker's work has been published and covered in the Indy Star, Skipping Stones Magazine, Charlotte Magazine and a number of other publications. Right Brain creatively emaciated, Walker decided to try his hand at screenwriting and has won over thirty screenplay awards and film festival selections to date. Throughout his career, Walker has endeavored to tell empowering stories about powerful people.","sameAs":["zeke.the.scribe","https://twitter.com/@zekethescribe"],"jobTitle":"Senior Writer","worksFor":"Ezekiel J. Walker","url":"https://theblackwallsttimes.com/author/zekeswriting/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Feed" href="https://theblackwallsttimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Comments Feed" href="https://theblackwallsttimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; &#8220;Forgive all student loan debt,&#8221; says former Obama Sec. of Education Comments Feed" href="https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.4.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-144364922-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<link rel='stylesheet' id='all-css-425c13995625db703b694035b5ece654' href='https://theblackwallsttimes.com/_static/??-eJydUVtOwzAQvBDOFpTSL8RZHHsx26wf8kNRbs+m7UdoA0H8WB7Pw97xlJSJoWKokLg5CgXOWJM2I/hoG2OBjKwrWpViqXeoM6U8TY8RrgkcMDsYGrGFgaMZFdOQdZ6h1Jnxf9b6if5HK+s5tqpcJvv9DgqGm5VRzgU8WtLIEiPONUhix6wYnTZz5ynsuoVb47Vnr1OmUdbNIi4jChcZrbbg9WPqnURY+BBK6QlLlH767tQdtp6zYSThfIx/kU6o5TSrxbIj//WLEwZDKqOhhJfg63avu0V52y/Sd//2/Nqf+uPL4dh/ATXIDhs=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='global-styles-css'  href='https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/' media='1' />
<style id='global-styles-inline-css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;display=swap' media='all' />
<link crossorigin="anonymous" rel="preload" as="style" onload="this.rel='stylesheet'" id="penci-fonts-css" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" type="text/css" media="all">
<noscript><link crossorigin="anonymous" id="penci-fonts-css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"></noscript>
<link rel='stylesheet' id='jetpack-global-styles-frontend-style-css'  href='https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/' media='1' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='monsterinsights-frontend-script-js-extra'>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/theblackwallsttimes.com","hash_tracking":"false","ua":"UA-144364922-1","v4_id":""};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJxlzMEKwjAMgOEXMssmY3gRH0Vim5XWLi1NRtnbK+JFPP6H/+sVXBFjMax5D1EUE1sl98R7FIePPWaPjTMZe6hFTX9r2KIMSU/9HwqlhMxAQvmw6BTW0qCX5mtjVSRVfmtJcW2f00MwCl/wtl2nZb6M83QelxfdJT3s'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??wp-includes/js/jquery/jquery-migrate.min.js,wp-content/plugins/stock-market-ticker/assets/stockdio-wp.js?m=1646158928'></script>
<link rel="https://api.w.org/" href="https://theblackwallsttimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theblackwallsttimes.com/wp-json/wp/v2/posts/63226" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theblackwallsttimes.com/xmlrpc.php?rsd" />

<link rel='shortlink' href='https://wp.me/p8q2YU-grM' />
<link rel="alternate" type="application/json+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.70.0" />	<style type="text/css">
				.penci-recipe-tagged .prt-icon span, .penci-recipe-action-buttons .penci-recipe-button:hover{ background-color:#21842b; }																																																																																															</style>
	<style type="text/css">
																											</style>
<link href="https://trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<script>var portfolioDataJs = portfolioDataJs || [];</script>			<link rel="preload" href="https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/fonts/hustle-icons-font.woff2" as="font" type="font/woff2" crossorigin>
		<style type='text/css'>img#wpstats{display:none}</style>
	<span id="ezoic-pub-video-placeholder-14"></span> 

<script>
   if (typeof(stockdio_events) == "undefined") {
      stockdio_events = true;
      var stockdio_eventMethod = window.addEventListener ? "addEventListener" : "attachEvent";
      var stockdio_eventer = window[stockdio_eventMethod];
      var stockdio_messageEvent = stockdio_eventMethod == "attachEvent" ? "onmessage" : "message";
      stockdio_eventer(stockdio_messageEvent, function (e) {
         if (typeof(e.data) != "undefined" && typeof(e.data.method) != "undefined") {
            eval(e.data.method);
         }
      },false);
   }
</script>
<iframe id='st_0afff0cc486140838dfcfb7db85ec13d' frameBorder='0' scrolling='no' width='100%' height='100%' src='https://api.stockdio.com/visualization/financial/charts/v1/Ticker?app-key=4153E1ADDFB447CBB3A7B9CF726D7D24&stockExchange=USA&symbols=AAPL;MSFT;GOOG;FB;ORCL&palette=Financial-Light&googleFont=true&backgroundColor=000000&labelsColor=ffffff&onload=st_0afff0cc486140838dfcfb7db85ec13d'></iframe>
<style id="penci-custom-style" type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
    },
    "url": "https:\/\/theblackwallsttimes.com\/",
    "name": "The Black Wall Street Times",
    "description": "Access is the New Civil Right"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Black Wall Street Times",
    "alternateName": "Access is the New Civil Right",
    "url": "https:\/\/theblackwallsttimes.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "\"Forgive all student loan debt,\" says former Obama Sec. of Education",
    "description": "Forgive all $1.75 trillion of debt Americans still owe on their student loans. That&#8217;s the shot-in-the-arm&hellip;",
    "datePublished": "2022-03-23",
    "datemodified": "2022-03-23",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2022\/03\/23\/forgive-all-student-loan-debt-says-former-obama-sec-of-education\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2022\/03\/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&ssl=1",
        "width": 2048,
        "height": 1365
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-EzekielJWalker",
        "name": "Ezekiel J. Walker"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "\"Forgive all student loan debt,\" says former Obama Sec. of Education",
    "image": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2022\/03\/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&ssl=1",
    "datePublished": "2022-03-23",
    "datemodified": "2022-03-23",
    "description": "",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2022\/03\/23\/forgive-all-student-loan-debt-says-former-obama-sec-of-education\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Ezekiel J. Walker"
    }
}</script>
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->

<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '402584430987857', {}, {
    "agent": "wordpress-5.9.2-3.0.6"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=402584430987857&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<!-- There is no amphtml version available for this URL. -->			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png" sizes="32x32" />
<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png" />
<meta name="msapplication-TileImage" content="https://theblackwallsttimes.com/wp-content/uploads/2022/02/Transparent-Background.png" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-54217030-32']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
<style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/theblackwallsttimes.com/kargobid.css" />

<script async src="https://htlbid.com/v3/theblackwallsttimes.com/kargobid.js" ></script>

<script>
  window.kargobid = window.kargobid || {};
  kargobid.cmd = kargobid.cmd || [];
  kargobid.cmd.push(function() {
    kargobid.layout('universal'); // Leave as 'universal' or add custom layout
    kargobid.setTargeting("is_testing","no"); // Set to "no" for production
    kargobid.setTargeting("is_home", "no"); // Set to "yes" on the homepage
    kargobid.setTargeting("category", "INSERT_CATEGORY_HERE"); // dynamically pass page category into this function
    kargobid.setTargeting("post_id", "INSERT_POSTID_HERE"); // dynamically pass unique post/page id into this function
  });
</script></head>

<body class="post-template-default single single-post postid-63226 single-format-standard wp-custom-logo elementor-default elementor-kit-40761">
	<div class='kargoad-BWSTimes_Desktop_Adhesion'></div>	<div class='code-block code-block-11 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Mobile_Adhesion'></div></div>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>	<a id="close-sidebar-nav" class="header-8"><i class="penci-faicon fa fa-close" ></i></a>
	<nav id="sidebar-nav" class="header-8" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">

					<div id="sidebar-nav-logo">
															<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2022/03/THE-BLACK-WALL-STREET-TIMES.jpg" alt="The Black Wall Street Times" /></a>
												</div>
		
					<div class="header-social sidebar-nav-social">
				<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>			</div>
				
		
		<ul id="menu-main-menu" class="menu"><li id="menu-item-47824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li id="menu-item-40827" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li id="menu-item-39304" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-41451" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li id="menu-item-40959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-41010" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li id="menu-item-30664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li id="menu-item-39303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li id="menu-item-40961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-17980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a>
<ul class="sub-menu">
	<li id="menu-item-57430" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-57430"><a href="https://theblackwallsttimes.com/tag/mental-health/">mental health</a></li>
</ul>
</li>
<li id="menu-item-15363" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li id="menu-item-52228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li id="menu-item-39301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li id="menu-item-41195" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li id="menu-item-39302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-29359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-41874" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li id="menu-item-40965" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
<li id="menu-item-57521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57521"><a href="https://theblackwallsttimes.com/podcasts/">Podcasts</a></li>
</ul>	</nav>
<div class="wrapper-boxed header-style-header-8 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar no-social topbar-fullwidth">
	<div class="container">
		<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
										<span class="headline-title">BREAKING NEWS</span>
														<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3500" data-speed="200">
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/03/09/florida-karen-throws-dog-from-apartment-window-kills-it-in-argument/">Florida Karen throws dog from apartment window, kills...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/01/24/lauren-smith-fields-cause-of-death-still-unknown-a-month-after-bumble-date-with-white-man/">Lauren Smith-Fields’ cause of death still unknown a...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/01/31/cheslie-kryst-former-miss-usa-commits-suicide/">Cheslie Kryst, former Miss USA, dies of suicide</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/03/10/quentin-liggins-passes-away-tulsa-community-remembers-his-legacy/">Quentin Liggins passes away; Tulsa community remembers his...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/02/21/ok-democrats-seek-new-candidate-after-abby-broyles-racist-rant/">OK Democrats seek new candidate after Abby Broyles&#8217;...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/02/26/marjorie-taylor-greene-just-headlined-a-white-supremacist-pro-putin-rally/">Marjorie Taylor Greene just headlined a white supremacist,...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/02/18/coach-deion-sanders-wants-to-build-a-new-stadium-at-jackson-state-university/">Deion Sanders wants to build a new stadium...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/03/11/tiger-woods-inducted-as-the-goat-in-world-golf-hall-of-fame/">Tiger Woods inducted as the GOAT in World...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/02/24/university-of-alabama-vice-president-issues-statement-following-arrest/">University of Alabama Vice President issues statement following...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2022/02/28/how-to-lose-a-community-in-10-days-the-gt-bynum-story/">How to Lose a Community in 10 Days:...</a>
							</div>
											</div>
									</div>
	</div>
</div><header id="header" class="header-header-8 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
			<div class="inner-header penci-header-second">
			<div class="container container-fullwidth">
				<div id="logo">
					<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2022/03/THE-BLACK-WALL-STREET-TIMES.jpg" alt="The Black Wall Street Times"/></a>									</div>

				
							</div>
		</div>
						<div class="sticky-wrapper">		<nav id="navigation" class="header-layout-bottom header-8 menu-style-2 penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
			<div class="container container-fullwidth">
				<div class="button-menu-mobile header-8"><i class="penci-faicon fa fa-bars" ></i></div>
								
				<ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-57430"><a href="https://theblackwallsttimes.com/tag/mental-health/">mental health</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57521"><a href="https://theblackwallsttimes.com/podcasts/">Podcasts</a></li>
</ul><div id="top-search" class="penci-top-search">
	<a class="search-click"><i class="penci-faicon fa fa-search" ></i></a>
	<div class="show-search">
		<form role="search" method="get" id="searchform" action="https://theblackwallsttimes.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>		<a class="search-click close-search"><i class="penci-faicon fa fa-close" ></i></a>
	</div>
</div>									<div class="main-nav-social">
						<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>					</div>
				
			</div>
		</nav><!-- End Navigation -->
		</div>	</header>
<!-- end #header -->

</div>

	<div class="penci-single-pheader container container-single penci_is_nosidebar container-single-fullwidth hentry">
			
	<div class="header-standard header-classic single-header">
					<div class="penci-standard-cat penci-single-cat"><span class="cat"><a class="penci-cat-name penci-cat-1342" href="https://theblackwallsttimes.com/category/education/"  rel="category tag">Education</a></span></div>
		
		<h1 class="post-title single-post-title entry-title">&#8220;Forgive all student loan debt,&#8221; says former Obama Sec. of Education</h1>
				<div class="penci-hide-tagupdated">
			<span class="author-italic author vcard">by <a class="url fn n" href="https://theblackwallsttimes.com/author/zekeswriting/">Ezekiel J. Walker</a></span>
			<time class="entry-date published" datetime="2022-03-23T10:10:33-04:00">March 23, 2022</time>		</div>
							<div class="post-box-meta-single">
									<span class="author-post byline"><span class="author vcard">by <a class="author-url url fn n" href="https://theblackwallsttimes.com/author/zekeswriting/">Ezekiel J. Walker</a></span></span>
													<span><time class="entry-date published" datetime="2022-03-23T10:10:33-04:00">March 23, 2022</time></span>
															</div>
					</div>



						<div class="post-image">
				<a href="https://theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg" data-rel="penci-gallery-image-content">											<img width="1170" height="780" src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=1170%2C780&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image jetpack-lazy-image" alt="&quot;Forgive all student loan debt,&quot; says former Obama Sec. of Education" data-attachment-id="63241" data-permalink="https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/20181217-edtrust-staffheadshots-0630-2/" data-orig-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=2048%2C1365&amp;ssl=1" data-orig-size="2048,1365" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20181217-EdTrust-StaffHeadshots-0630" data-image-description="" data-image-caption="&lt;p&gt;John King, former Secretary of Education under President Obama. (Education Trust)&lt;/p&gt;
" data-medium-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=1024%2C683&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?w=2048&amp;ssl=1 2048w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=1536%2C1024&amp;ssl=1 1536w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=1200%2C800&amp;ssl=1 1200w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=1920%2C1280&amp;ssl=1 1920w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=1170%2C780&amp;ssl=1 1170w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=585%2C390&amp;ssl=1 585w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?resize=263%2C175&amp;ssl=1 263w" data-lazy-sizes="(max-width: 1170px) 100vw, 1170px" data-lazy-src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/20181217-EdTrust-StaffHeadshots-0630.jpeg?fit=1170%2C780&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a><div class="penci-featured-caption">John King, former Secretary of Education under President Obama. (Education Trust)</div>			</div>
			

		</div>

<div class="container container-single penci_is_nosidebar penci-single-smaller-width penci-enable-lightbox">
	<div id="main" class="penci-main-sticky-sidebar">
		<div class="theiaStickySidebar">
											<article id="post-63226" class="post type-post status-publish">

	
				
	
		<div class="tags-share-box tags-share-box-top tags-share-box-2_3 tags-share-box-s3">
		<span class="penci-social-share-text">Share</span>		
					<div class="post-share hide-like-count">
				
				<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank"  href="https://www.facebook.com/sharer/sharer.php?u=https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank"  href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20%22Forgive%20all%20student%20loan%20debt%2C%22%20says%20former%20Obama%20Sec.%20of%20Education%20-%20https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" target="_blank"  href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F&#038;title=%22Forgive%20all%20student%20loan%20debt%2C%22%20says%20former%20Obama%20Sec.%20of%20Education"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-email" target="_blank"  href="mailto:?subject=Forgive%20all%20student%20loan%20debt,%20says%20former%20Obama%20Sec.%20of%20Education&#038;BODY=https://theblackwallsttimes.com/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a></div>			</div>
			</div>
	<div class="post-entry blockquote-style-2">
		<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
			
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script nitro-exclude data-trinity-mount-date='2022-03-23 18:01:48'>var TRINITY_TTS_WP_CONFIG = {"cleanText":"\u201cForgive all student loan debt,\u201d says former Obama Sec. of Education. Forgive all $1.75 trillion of debt Americans still owe on their student loans. That's the shot-in-the-arm our \"post-pandemic\" country needs to speed economic recovery, according to former U.S. Secretary of Education John King.\r\n\r\nKing, who served under President Barack Obama, told CBS News that the federal government paid roughly 80% of the cost of college for students through its Pell grant program in the 1980s. But the government's move in recent decades to cut its investment in higher education has left many students deeply in debt, with today's Pell program covering less than a third of annual tuition for grant recipients.\r\n\r\nWithout the burden of student loans, the Roosevelt Institute estimates Black wealth could increase by up to 40%.\r\n\r\nMore than 43 million Americans \u2014 nearly 13% of the U.S. population \u2014 carry student debt,\u00a0according\u00a0to the St. Louis Federal Reserve. The average borrower owes about $37,000.\r\nDebt holds many households back.\r\n\r\n\r\n\r\n\r\n\r\nRecently the\u00a0Roosevelt Institute, a progressive think-tank, conducted a study on student loan borrowers. The study noted that forgiving student loans\u00a0 \u201cwould provide more benefits to those with fewer economic resources and could play a critical role in addressing the racial wealth gap and building the Black middle class. The reason for this progressivity is simple: People from wealthy backgrounds (and their parents) rarely use student loans to pay for college.\u201d\r\n\r\n\r\n\r\n\r\n\r\nThat anvil of debt often weighs borrowers down for years, forcing them to postpone plans to buy a home, start a business or even have children, King said. Programs such as 2020's CARES Act proved beneficial for student loan borrowers. Yet, it didn't leave much of a dent in the total $1.7 trillion price tag of higher education.\r\nWill President Biden forgive all student loan debt?\r\nPer UCI News, in his first year-plus in office, President Biden has canceled about $16 billion in federal student loan debt through programs primarily targeted at borrowers with disabilities, students who were defrauded by their institutions, and people who work in public service.\r\n\r\nOther Democrats, including Senators Elizabeth Warren and Chuck Schumer and U.S. Rep. Alexandria Ocasio-Cortez have also urged the Biden-Harris Administration to cancel student loans. Meanwhile, Pres. Biden has yet to make the ultimate executive decision.\r\n\r\nThe White House, dating back to 2020 under President Donald Trump, placed an interest-free forbearance on student loan payments during the pandemic. As a result, since March 2020 nearly 37 million borrowers have been excused from making payments on their student loans \u2014 an estimated $195 billion worth of waived payments, according to the\u00a0New York Federal Reserve. But the forbearance ends May 1, and many borrowers are worried about being able to resume payments.\r\n\r\n\"We've got to make up for that policy mistake of the last 40 years by addressing the crushing burden of student debt that so many young people feel today and fixing the problem going forward by committing to debt-free college in the United States,\" King said.\r\n\r\nCurrent Education Secretary Miguel Cardona told CBS Mornings last week that Biden administration officials are talking internally about how to offer more student loan debt relief.","pluginVersion":"4.2.4"};</script><div class='trinityAudioPlaceholder' data-trinity-mount-date='2022-03-23 18:01:48'></div>
                </td>
            </tr>
        </table><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<!--<script src="https://cdn.jwplayer.com/players/1932deGs-uZx2u7Da.js"></script>--></div>
<p>Forgive all $1.75 trillion of debt Americans still owe on their student loans. That&#8217;s the shot-in-the-arm our &#8220;post-pandemic&#8221; country needs to speed economic recovery, according to former U.S. Secretary of Education John King.</p><div class='code-block code-block-12 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Mobile_InArticle_1'></div></div>
<div class='code-block code-block-2 ai-viewport-1' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Desktop_InArticle_1'></div></div>

<p>King, who served under President Barack Obama, told <a href="https://www.cbsnews.com/news/student-loan-debt-john-king-college/">CBS News</a> that the federal government paid roughly 80% of the cost of college for students through its Pell grant program in the 1980s. But the government&#8217;s move in recent decades to cut its investment in higher education has left many students deeply in debt, with today&#8217;s Pell program covering less than a third of annual tuition for grant recipients.</p>
<p>Without the burden of student loans, the Roosevelt Institute estimates <a href="https://www.bloomberg.com/news/articles/2021-12-20/calls-for-biden-to-cancel-50-000-student-debt-could-boost-black-wealth-by-40">Black wealth could increase by up to 40%</a>.</p>
<p>More than 43 million Americans — nearly 13% of the U.S. population — carry student debt, <a href="https://fred.stlouisfed.org/series/SLOAS" target="_blank" rel="nofollow noopener" data-saferedirecturl="https://www.google.com/url?q=https://fred.stlouisfed.org/series/SLOAS&amp;source=gmail&amp;ust=1648124198272000&amp;usg=AOvVaw3E_mjzlHtwCddUhslFuV23">according</a> to the St. Louis Federal Reserve. The average borrower owes about $37,000.</p><div class='code-block code-block-13 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Mobile_InArticle_2'></div></div>
<div class='code-block code-block-3 ai-viewport-1' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Desktop_InArticle_2'></div></div>

<h2>Debt holds many households back.</h2>
<div class="code-block code-block-2 ai-viewport-1">
<div class="kargoad-BWSTimes_Desktop_InArticle_1">
<div id="kargoad-4" class="kargo-ad htlunit-BWSTimes_Desktop_InArticle_1" data-unit="BWSTimes_Desktop_InArticle_1" data-eager="" data-sizes="790x0:300x250,320x50,728x90,840x280|0x0:" data-prebid="790x0:DesktopInArticle|0x0:">
<div id="kargoad-4-gpt" class="kargo-ad-gpt htl-size-300x250" data-google-query-id="CL_jnreh3PYCFYn74wcdQx0PeA">
<p>Recently the <a href="https://rooseveltinstitute.org/2021/12/08/how-canceling-student-debt-would-bolster-the-economic-recovery-and-reduce-the-racial-wealth-gap/#:~:text=For%20example%2C%20analysis%20in%20a,Black%20Americans%20by%2040%20percent.">Roosevelt Institute, a progressive think-tank, conducted a study on student loan borrowers</a>. The study noted that forgiving student loans  “would provide more benefits to those with fewer economic resources and could play a critical role in addressing the racial wealth gap and building the Black middle class. The reason for this progressivity is simple: People from wealthy backgrounds (and their parents) rarely use student loans to pay for college.”</p>
</div>
</div>
</div>
</div>
<p>That anvil of debt often weighs borrowers down for years, forcing them to postpone plans to buy a home, start a business or even have children, King said. Programs such as 2020&#8217;s CARES Act proved beneficial for student loan borrowers. Yet, it didn&#8217;t leave much of a dent in the total $1.7 trillion price tag of higher education.</p>
<h2><a href="https://theblackwallsttimes.com/2021/12/27/study-forgiving-student-loan-debt-would-increase-black-wealth/">Will President Biden forgive all student loan debt?</a></h2>
<p>Per <a href="https://news.uci.edu/2022/03/21/whats-next-student-loan-debt-forgiveness/">UCI News</a>, in his first year-plus in office, President Biden has canceled about $16 billion in federal student loan debt through programs primarily targeted at borrowers with disabilities, students who were defrauded by their institutions, and people who work in public service.</p><div class='code-block code-block-14 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Mobile_InArticle_3'></div></div>
<div class='code-block code-block-5 ai-viewport-1' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Desktop_InArticle_3'></div></div>

<p>Other Democrats, including Senators Elizabeth Warren and Chuck Schumer and U.S. Rep. <a href="https://fortune.com/education/business/articles/2022/02/16/aoc-everyone-should-get-their-student-loans-canceled-including-harvard-and-yale-grads/">Alexandria Ocasio-Cortez</a> have also urged the Biden-Harris Administration to cancel student loans. Meanwhile, Pres. Biden has yet to make the ultimate executive decision.</p>
<p>The White House, dating back to 2020 under President Donald Trump, placed an interest-free forbearance on student loan payments during the pandemic. As a result, since March 2020 nearly 37 million borrowers have been excused from making payments on their student loans — an estimated $195 billion worth of waived payments, according to the <a href="https://libertystreeteconomics.newyorkfed.org/2022/03/student-loan-repayment-during-the-pandemic-forbearance/" target="_blank" rel="nofollow noopener" data-saferedirecturl="https://www.google.com/url?q=https://libertystreeteconomics.newyorkfed.org/2022/03/student-loan-repayment-during-the-pandemic-forbearance/&amp;source=gmail&amp;ust=1648124198272000&amp;usg=AOvVaw0d7mOZqPtB5DNli4_AKgln">New York Federal Reserve</a>. But the forbearance ends May 1, and many borrowers are worried about being able to resume payments.</p>
<p>&#8220;We&#8217;ve got to make up for that policy mistake of the last 40 years by addressing the crushing burden of student debt that so many young people feel today and fixing the problem going forward by committing to debt-free college in the United States,&#8221; King said.</p><div class='code-block code-block-15 ai-viewport-3' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Mobile_InArticle_4'></div></div>
<div class='code-block code-block-6 ai-viewport-1' style='margin: 8px 0; clear: both;'>
<div class='kargoad-BWSTimes_Desktop_InArticle_4'></div></div>

<p>Current Education Secretary Miguel Cardona told <a href="https://www.cbsnews.com/news/secretary-of-education-miguel-cardona-student-loan-system/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://www.cbsnews.com/news/secretary-of-education-miguel-cardona-student-loan-system/&amp;source=gmail&amp;ust=1648124198272000&amp;usg=AOvVaw3XsS_lNhvCjfnPvXhT1icH">CBS Mornings</a> last week that Biden administration officials are talking internally about how to offer more student loan debt relief.</p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div><!-- AI CONTENT END 2 -->
			
			<div class="penci-single-link-pages">
						</div>
			
												<div class="post-tags">
						<a href="https://theblackwallsttimes.com/tag/cares-act/" rel="tag">CARES Act</a><a href="https://theblackwallsttimes.com/tag/free-college/" rel="tag">Free College</a><a href="https://theblackwallsttimes.com/tag/national-news/" rel="tag">National News</a><a href="https://theblackwallsttimes.com/tag/student-loan-forgiveness/" rel="tag">student loan forgiveness</a><a href="https://theblackwallsttimes.com/tag/student-loans/" rel="tag">student loans</a>					</div>
									</div>
	</div>

			<div class="penci-google-adsense-2">
			
		</div>
	
		
	
			<div class="post-author">
	<div class="author-img">
		<img alt src="https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=100&#038;d=identicon&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=200&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=100&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=100&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/ab5f63569809f73acd04fd862c4fbdbf?s=200&#038;d=identicon&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/></noscript>	</div>
	<div class="author-content">
		<h5><a href="https://theblackwallsttimes.com/author/zekeswriting/" title="Posts by Ezekiel J. Walker" rel="author">Ezekiel J. Walker</a></h5>
		<p>Hailing from Charlotte North Carolina, born litterateur and movie junky Ezekiel J. Walker has been writing since forever ago. Shortly after earning a B.A. in Psychology at Winston Salem State University, Walker released his first creative nonfiction book and has gone on to author two subsequent books related to African American culture. Walker's work has been published and covered in the Indy Star, Skipping Stones Magazine, Charlotte Magazine and a number of other publications. Right Brain creatively emaciated, Walker decided to try his hand at screenwriting and has won over thirty screenplay awards and film festival selections to date. Throughout his career, Walker has endeavored to tell empowering stories about powerful people.</p>
									<a  target="_blank" class="author-social" href="http://twitter.com/@zekethescribe"><i class="penci-faicon fa fa-twitter" ></i></a>
							<a  target="_blank" class="author-social" href="http://instagram.com/zeke.the.scribe"><i class="penci-faicon fa fa-instagram" ></i></a>
																	<a class="author-social" href="mailto:zeke@bwstimes.com"><i class="penci-faicon fa fa-envelope" ></i></a>
			</div>
</div>	
	
		
		
	
	
	
		
			<div class="post-comments no-comment-yet penci-comments-hide-0" id="comments">
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/03/23/forgive-all-student-loan-debt-says-former-obama-sec-of-education/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&#038;postid=63226&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.8-a.7&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=06d670e9eb114759f73927aff676406b64680f57#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div> <!-- end comments div -->
		
	
	
	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
				<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
								<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/santi-vedri-707620-unsplash.jpeg?resize=585%2C393&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/22/urban-league-councilwoman-nice-to-co-host-okcps-candidate-forum/" title="Urban League, Councilwoman Nice to co-host OKCPS candidate forum">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/22/urban-league-councilwoman-nice-to-co-host-okcps-candidate-forum/">Urban League, Councilwoman Nice to co-host OKCPS candidate...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-22T12:59:37-04:00">March 22, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-8-e1647625230771.jpg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/18/ralph-lauren-partners-with-hbcus-morehouse-and-spelman/" title="Ralph Lauren partners with HBCUs Morehouse and Spelman">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/18/ralph-lauren-partners-with-hbcus-morehouse-and-spelman/">Ralph Lauren partners with HBCUs Morehouse and Spelman</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-18T13:43:21-04:00">March 18, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/HL14-HowardUniversity.jpeg?resize=585%2C540&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/18/howard-university-faculty-plan-strike-if-working-conditions-dont-improve/" title="Howard University faculty plan strike if working conditions don&#8217;t improve">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/18/howard-university-faculty-plan-strike-if-working-conditions-dont-improve/">Howard University faculty plan strike if working conditions...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-18T11:38:50-04:00">March 18, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-2022-03-16T103841.336.jpg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/16/north-carolina-superintendent-apologizes-for-mock-slave-auction/" title="North Carolina superintendent apologizes for &#8220;mock slave auction&#8221;">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/16/north-carolina-superintendent-apologizes-for-mock-slave-auction/">North Carolina superintendent apologizes for &#8220;mock slave auction&#8221;</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-16T11:42:23-04:00">March 16, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-2022-03-16T100339.617.jpg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/16/florida-h-s-apologizes-after-telling-student-to-cut-locs-for-graduation/" title="Florida H.S. apologizes after telling student to cut locs for graduation">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/16/florida-h-s-apologizes-after-telling-student-to-cut-locs-for-graduation/">Florida H.S. apologizes after telling student to cut...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-16T11:07:46-04:00">March 16, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/IMG_9659-e1647267449308.jpeg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/14/monroe-8th-graders-practice-college-entrance-exam-in-historic-greenwood/" title="Monroe 8th graders practice college entrance exam in Historic Greenwood">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/14/monroe-8th-graders-practice-college-entrance-exam-in-historic-greenwood/">Monroe 8th graders practice college entrance exam in...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-14T10:19:36-04:00">March 14, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-2022-03-10T133615.937.jpg?resize=585%2C332&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/10/opinion-take-liberty-and-justice-for-all-out-of-the-pledge-of-allegiance/" title="Opinion: Take “liberty and justice for all&#8221; out of the Pledge of Allegiance">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/10/opinion-take-liberty-and-justice-for-all-out-of-the-pledge-of-allegiance/">Opinion: Take “liberty and justice for all&#8221; out...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-10T14:43:59-05:00">March 10, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-2022-03-10T112213.667-e1646933643225.jpg?resize=585%2C580&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/10/mo-williams-nba-champ-to-join-jackson-state-as-head-basketball-coach/" title="Mo Williams, NBA champ, to join Jackson State as head basketball coach">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/10/mo-williams-nba-champ-to-join-jackson-state-as-head-basketball-coach/">Mo Williams, NBA champ, to join Jackson State...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-10T12:53:20-05:00">March 10, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/morrisbrown_james_courtesy-e1646327321221.jpeg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/03/hbcu-morris-brown-college-partners-with-historic-masonic-fraternity/" title="HBCU Morris Brown College partners with historic masonic fraternity">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/03/hbcu-morris-brown-college-partners-with-historic-masonic-fraternity/">HBCU Morris Brown College partners with historic masonic...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-03T12:12:18-05:00">March 3, 2022</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Untitled-design-89.jpg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/01/learning-black-history-should-be-a-tradition-not-a-trend/" title="Learning Black History should be a tradition, not a trend">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2022/03/01/learning-black-history-should-be-a-tradition-not-a-trend/">Learning Black History should be a tradition, not...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2022-03-01T17:04:38-05:00">March 1, 2022</time></span>
									</div>
		</div></div>		
		
	
	
			<div class="post-pagination">
				<div class="prev-post">
												<a class="penci-post-nav-thumb" href="https://theblackwallsttimes.com/2022/03/22/gop-senator-says-states-should-be-allowed-to-outlaw-interracial-marriage/" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/braun.jpeg?resize=150%2C150&#038;ssl=1');">
					</a>
										<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="https://theblackwallsttimes.com/2022/03/22/gop-senator-says-states-should-be-allowed-to-outlaw-interracial-marriage/">
					<div class="pagi-text">
						<h5 class="prev-title">GOP Senator says states should be allowed to outlaw interracial marriage</h5>
					</div>
				</a>
			</div>
		</div>
	
			<div class="next-post">
												<a class="penci-post-nav-thumb nav-thumb-next" href="https://theblackwallsttimes.com/2022/03/23/prison-escape-is-short-lived-as-inmate-is-fatally-shot-by-texarkana-police/" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/IMG_1313_t800.jpeg?resize=150%2C150&#038;ssl=1');">
					</a>
										<div class="next-post-inner">
				<div class="prev-post-title next-post-title">
					<span>next post</span>
				</div>
				<a href="https://theblackwallsttimes.com/2022/03/23/prison-escape-is-short-lived-as-inmate-is-fatally-shot-by-texarkana-police/">
					<div class="pagi-text">
						<h5 class="next-title">Prison escape is short-lived as inmate is fatally shot by Texarkana Police</h5>
					</div>
				</a>
			</div>
		</div>
	</div>	
		
		
		
	
</article>					</div>
	</div>
	<!-- END CONTAINER -->
</div>

<div class="clear-footer"></div>


		<div id="widget-area">
			<div class="container">
									<div class="footer-widget-wrapper footer-widget-style-10">
						<aside id="pages-18" class="widget widget_pages"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Pages</span></h4>
			<ul>
				<li class="page_item page-item-53674"><a href="https://theblackwallsttimes.com/advertising/">Advertising</a></li>
<li class="page_item page-item-46613"><a href="https://theblackwallsttimes.com/freelance-opinion-piece-submissions/">Freelance &#038; Opinion Piece Submissions</a></li>
<li class="page_item page-item-46678"><a href="https://theblackwallsttimes.com/">Home Page</a></li>
<li class="page_item page-item-56959"><a href="https://theblackwallsttimes.com/careers/">Job &#038; Career Opportunities</a></li>
<li class="page_item page-item-51194"><a href="https://theblackwallsttimes.com/ownership-funding/">Ownership &#038; Funding</a></li>
<li class="page_item page-item-57498"><a href="https://theblackwallsttimes.com/podcasts/">Podcasts</a></li>
<li class="page_item page-item-51178"><a href="https://theblackwallsttimes.com/publishing-policies/">Publishing Policies</a></li>
<li class="page_item page-item-45157"><a href="https://theblackwallsttimes.com/team/">Staff</a></li>
			</ul>

			</aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-10 last">
						<aside id="penci_related_news_widget-4" class="widget penci_related_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Related Post</span></h4>					<ul id="penci-relatedwg-6318" class="side-newsfeed">
													<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/Copy-of-MAYA-FORD_PRINCIPAL-e1648055258232.jpg?resize=585%2C585&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/23/black-owned-data-firm-dismantles-white-supremacy-across-the-nation/" title="Black-owned data firm dismantles White supremacy across the nation "></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2022/03/23/black-owned-data-firm-dismantles-white-supremacy-across-the-nation/" rel="bookmark" title="Black-owned data firm dismantles White supremacy across the nation ">
												Black-owned data firm dismantles White supremacy across the nation 											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2022-03-23T13:10:25-04:00">March 23, 2022</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/IMG_1313_t800.jpeg?resize=585%2C507&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/23/prison-escape-is-short-lived-as-inmate-is-fatally-shot-by-texarkana-police/" title="Prison escape is short-lived as inmate is fatally shot by Texarkana Police"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2022/03/23/prison-escape-is-short-lived-as-inmate-is-fatally-shot-by-texarkana-police/" rel="bookmark" title="Prison escape is short-lived as inmate is fatally shot by Texarkana Police">
												Prison escape is short-lived as inmate is fatally shot by Texarkana Police											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2022-03-23T12:15:05-04:00">March 23, 2022</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/03/braun.jpeg?resize=400%2C282&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/03/22/gop-senator-says-states-should-be-allowed-to-outlaw-interracial-marriage/" title="GOP Senator says states should be allowed to outlaw interracial marriage"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2022/03/22/gop-senator-says-states-should-be-allowed-to-outlaw-interracial-marriage/" rel="bookmark" title="GOP Senator says states should be allowed to outlaw interracial marriage">
												GOP Senator says states should be allowed to outlaw interracial marriage											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2022-03-22T18:43:54-04:00">March 22, 2022</time></span>
																			</div>
								</div>
							</li>
												</ul>

				</aside>					</div>
							</div>
		</div>


	<div class="footer-subscribe">
			</div>

<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
	<div class="container">
					<div class="footer-socials-section">
				<ul class="footer-socials">
											<li><a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i><span>Facebook</span></a></li>
																<li><a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i><span>Twitter</span></a></li>
																<li><a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i><span>Instagram</span></a></li>
																<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i><span>Pinterest</span></a></li>
																<li><a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i><span>Linkedin</span></a></li>
																															<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i><span>Youtube</span></a></li>
																																																																																																																																																																	<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i><span>tiktok</span></a></li>
									</ul>
			</div>
											<div class="penci-go-to-top-floating"><i class="penci-faicon fa fa-angle-up" ></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>
<div
				class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_8 module_id_8  "
				
			data-id="8"
			data-render-id="0"
			data-tracking="disabled"
			
				data-intro="no_animation"
				data-outro="no_animation"
				data-overlay-close="1"
				data-close-delay="false"
				
				style="opacity: 0;"
			><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-optin hustle-optin--default"><button class="hustle-button-icon hustle-button-close has-background">
			<span class="hustle-icon-close" aria-hidden="true"></span>
			<span class="hustle-screen-reader">Close this module</span>
		</button><div class="hustle-success" data-close-delay="false" style="display: none;"><span class="hustle-icon-check" aria-hidden="true"></span><div class="hustle-success-content"></div></div><div class="hustle-layout"><div class="hustle-layout-body"><div class="hustle-layout-content hustle-layout-position--above"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://theblackwallsttimes.com/wp-content/uploads/2020/12/BWSTimes-Bubble-Logo-.png" alt="" class="hustle-image-position--centercenter" /></div><div class="hustle-content"><div class="hustle-content-wrap"><div class="hustle-group-title"><span class="hustle-title">THE BLACK WALL STREET TIMES</span></div><div class="hustle-group-content"><p style="text-align: center">Support Black-owned media, learn our stories and diverse perspectives by subscribing below.</p></div></div></div></div><form class="hustle-layout-form" novalidate="novalidate"><div class="hustle-form hustle-form-inline"><div class="hustle-form-fields hustle-proximity-separated"><div class="hustle-field hustle-field-required "><label for="hustle-field-email-module-8" id="hustle-field-email-module-8-label" class="hustle-screen-reader">Email</label><input id="hustle-field-email-module-8" type="email" class="hustle-input " name="email" value="" aria-labelledby="hustle-field-email-module-8-label" data-validate="1" data-required-error="Email field is required." data-validation-error="Please enter a valid email." /><span class="hustle-input-label" aria-hidden="true" style="flex-flow: row nowrap;"><span>Enter your email address</span></span></div><button class="hustle-button hustle-button-submit " aria-live="polite" data-loading-text="Form is being submitted, please wait a bit."><span class="hustle-button-text">Subscribe</span><span class="hustle-icon-loader hustle-loading-icon" aria-hidden="true"></span></button></div></div><input type="hidden" name="hustle_module_id" value="8"><input type="hidden" name="post_id" value="63226"><div class="hustle-error-message" style="display: none;" data-default-error="Something went wrong, please try again."></div></form></div></div></div></div></div><!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202212'></script>
	<div style="display:none">
			<div class="grofile-hash-map-ab5f63569809f73acd04fd862c4fbdbf">
		</div>
		</div>
		    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div><link rel='stylesheet' id='all-css-7f903b2fab4086dd783300f8c9527e43' href='https://theblackwallsttimes.com/_static/??-eJytzF0KhDAQA+ALWWfFsu6LeBZ/ihZqZzBTen2LoBdYHxOSL4uZOaqLShLS6iMo87HI4QAjLEloBJyCtgQNziRPM57kyxn17mNdyir/h62BpzG8pbFogV7CrsWNDXvffG1n29+nsyetRXrV' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='hustle-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A700%2Cregular%2C500%2C400&#038;display=swap' media='all' />
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJx9j+EKwjAMhF/ILahl+Ed8FOmy4NJ1aW1Tx97eiYOBor8uhPsuuSlWGERJFKIvN5YMjjRaHODKgtAW9h3EPmiQVeqRpXZ5N32jGFofcMjQcVZw26KywqNVDr/ISIJcJXowTS/Q3QuluSab58iEvU365+4n/Z5W81LDl47yFguFl88SrYmX8bxvzPFkmsYcnjI/ZrA='></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script>
<script id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script id='hui_scripts-js-extra'>
var hustleSettings = {"mobile_breakpoint":"782"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/js/hustle-ui.min.js?m=1647438074'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script id='hustle_front-js-extra'>
var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"0","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["scroll"]},"animation_in":"no_animation","animation_out":"no_animation","after_close":"no_show_all","expiration":365,"expiration_unit":"days","on_submit":"close","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"no_show_all","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"10\/23\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"10\/29\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5","after_close_trigger":["click_close_icon"]},"module_id":"8","blog_id":"0","module_name":"The Weekly | The Black Wall Street Times","module_type":"popup","active":"1","module_mode":"optin"}];
var incOpt = {"conditional_tags":{"is_single":true,"is_tag":false,"is_category":false,"is_author":false,"is_date":false,"is_post_type_archive":false,"is_404":false,"is_front_page":false,"is_search":false},"is_admin":"","real_page_id":"","thereferrer":"","actual_url":"theblackwallsttimes.com\/2022\/03\/23\/forgive-all-student-loan-debt-says-former-obama-sec-of-education\/","full_actual_url":"https:\/\/theblackwallsttimes.com\/2022\/03\/23\/forgive-all-student-loan-debt-says-former-obama-sec-of-education\/","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education&text=%E2%80%9CForgive%20all%20student%20loan%20debt%2C%E2%80%9D%20says%20former%20Obama%20Sec.%20of%20Education","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education","email":"mailto:?subject=%E2%80%9CForgive%20all%20student%20loan%20debt%2C%E2%80%9D%20says%20former%20Obama%20Sec.%20of%20Education&body=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education"},"ajaxurl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","page_id":"63226","page_slug":"2022-03-23-forgive-all-student-loan-debt-says-former-obama-sec-of-education","is_upfront":"","script_delay":"3000"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/js/front.min.js?m=1647438074'></script>
<script src='https://secure.gravatar.com/js/gprofiles.js' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script id='main-scripts-js-extra'>
var ajax_var_more = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"01832e1fc0","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_like_post-js-extra'>
var ajax_var = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"01832e1fc0","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_archive_more_scroll-js-extra'>
var SOLEDADLOCALIZE = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"01832e1fc0","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='penci_rateyo-js-extra'>
var PENCI = {"ajaxUrl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"01832e1fc0"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJytkN1OwzAMRl+INPyISb1APMqUJVbrLo6D7bYqT08mhkATMC64imSfY/vLWl3kYlDM1zwPWNRPYDXEoydOcwb1ax2ER+4mvVk/aRuBWlM5QwrJT+ozHtRpFKzWEZarPIU/QJXVXMYjXCWDxBEXcMQC7qSdDSwxz6mxjYlM1GwnUPP2zZGXX3B+9wuUxOLDbEzBDONHx+XwujmkMLQFCdU8tkmiEA25OD4oyALy/2u+FH4YXqFEbEkjVjhln15mkK2TYLDxL9kvvSZgGfbvheY809Pd7qF/vO373f0b+ufa0w=='></script>
<script src='https://theblackwallsttimes.com/wp-content/plugins/trinity-audio/js/the_content-hook-script.js' id='the_content-hook-script-js'></script>
<script id='the_content-hook-script-js-after'>
console.debug('TRINITY_WP', 'Skip player from rendering', 'is single: 1, is main loop: , is main query: 1', 'TS: 2022-03-23 18:01:48');
</script>
<script nitro-exclude data-wpfc-render='false' data-trinity-mount-date='2022-03-23 18:01:48' src='https://trinitymedia.ai/player/trinity/aed191ad3370a2904d9166b821fb5dec/?postHash=141596589bbf2bdc4933c4aa8a411d80&#038;poweredby=1&#038;language=en-US&#038;voiceGender=m&#038;pageURL=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F' id='trinity-player-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=63226&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.8-a.7&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=06d670e9eb114759f73927aff676406b64680f57#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=63226&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.8-a.7&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=06d670e9eb114759f73927aff676406b64680f57#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F03%2F23%2Fforgive-all-student-loan-debt-says-former-obama-sec-of-education%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202212.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.8-a.7',blog:'124418680',post:'63226',tz:'-4',srv:'theblackwallsttimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '124418680', '63226' ]);
</script>
<script type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script>
	<style type="text/css" id="hustle-module-8-0-styles" class="hustle-module-styles hustle-module-styles-8">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</style>

<amp-ad width=728 height=90 type="adbutler" data-account="181918" data-zone=""> </amp-ad>

</body>
</html>
<!--
	generated in 0.733 seconds
	217713 bytes batcached for 300 seconds
-->
