<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg">
		<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times RSS Feed" href="https://theblackwallsttimes.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="The Black Wall Street Times Atom Feed" href="https://theblackwallsttimes.com/feed/atom/" />
	<link rel="pingback" href="https://theblackwallsttimes.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://theblackwallsttimes.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	<link rel='preconnect' href='https://fonts.googleapis.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<meta http-equiv='x-dns-prefetch-control' content='on'>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='preload' as='image' href='https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png' type='image/png'>
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/icomoon.woff' type='font/woff' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/weathericons.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/plugins/penci-recipe/fonts/ficon.woff2' type='image/woff2' crossorigin='anonymous'>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Merriweather:r:latin,latin-ext","Merriweather:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://theblackwallsttimes.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css"></style>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.8 (Yoast SEO v17.8) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Twitter permanently bans Rep. Marjorie Taylor Greene </title>
	<meta name="description" content="Twitter bans U.S. Rep. Marjorie Taylor Greene from its social media platform permanently for violating its policy." />
	<link rel="canonical" href="https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Twitter permanently bans Rep. Marjorie Taylor Greene " />
	<meta property="og:description" content="Twitter bans U.S. Rep. Marjorie Taylor Greene from its social media platform permanently for violating its policy." />
	<meta property="og:url" content="https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/" />
	<meta property="og:site_name" content="The Black Wall Street Times" />
	<meta property="article:publisher" content="https://www.facebook.com/BWSTimes" />
	<meta property="article:author" content="@BWSTimes" />
	<meta property="article:published_time" content="2022-01-02T19:20:55+00:00" />
	<meta property="article:modified_time" content="2022-01-02T19:30:42+00:00" />
	<meta property="og:image" content="https://theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="533" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:description" content="Twitter bans U.S. Rep. Marjorie Taylor Greene from its social media platform permanently for violating its policy." />
	<meta name="twitter:creator" content="@TheBWSTimes" />
	<meta name="twitter:site" content="@TheBWSTimes" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="The Black Wall Street Times" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://theblackwallsttimes.com/#website","url":"https://theblackwallsttimes.com/","name":"The Black Wall Street Times","description":"Access is the New Civil Right","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://theblackwallsttimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&ssl=1","contentUrl":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&ssl=1","width":800,"height":533,"caption":"Rep. Marjorie Taylor Greene, R-Ga., listens during a news conference about the treatment of people being held in the District of Columbia jail who are charged with crimes in the Jan. 6 insurrection, at the Capitol in Washington, Tuesday, Dec. 7, 2021. Twitter on Sunday, Jan. 2, 2022, banned the personal account of Greene for multiple violations of its COVID-19 misinformation policy, according to a statement from the company. (AP Photo/J. Scott Applewhite, File)"},{"@type":"WebPage","@id":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#webpage","url":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/","name":"Twitter permanently bans Rep. Marjorie Taylor Greene\u00a0","isPartOf":{"@id":"https://theblackwallsttimes.com/#website"},"primaryImageOfPage":{"@id":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#primaryimage"},"datePublished":"2022-01-02T19:20:55+00:00","dateModified":"2022-01-02T19:30:42+00:00","author":{"@id":"https://theblackwallsttimes.com/#/schema/person/25167fa94e9b489ee3a831baf5048938"},"description":"Twitter bans U.S. Rep. Marjorie Taylor Greene from its social media platform permanently for violating its policy.","breadcrumb":{"@id":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/"]}]},{"@type":"BreadcrumbList","@id":"https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://theblackwallsttimes.com/"},{"@type":"ListItem","position":2,"name":"Twitter permanently bans Rep. Marjorie Taylor Greene\u00a0"}]},{"@type":"Person","@id":"https://theblackwallsttimes.com/#/schema/person/25167fa94e9b489ee3a831baf5048938","name":"The Black Wall Street Times","image":{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=96&d=identicon&r=g","caption":"The Black Wall Street Times"},"description":"The Black Wall Street Times is a news publication located in Tulsa, Okla. and Atlanta, Ga. At The BWSTimes, we focus on elevating the stories of our beloved Greenwood community, elevating the stories of the Black American experience and speaking truth to power. SignUp for our free newsletter on our home page and follow us on social media to keep up with our latest work.","sameAs":["http://www.bwstimes.com","@BWSTimes","thebwstimes","https://www.linkedin.com/company/bwstimes","https://www.youtube.com/channel/UCZJJEGEW3Mri0ojXV-rVjVg"],"url":"https://theblackwallsttimes.com/author/theblackwallsttimes/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Feed" href="https://theblackwallsttimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Comments Feed" href="https://theblackwallsttimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Twitter permanently bans Rep. Marjorie Taylor Greene  Comments Feed" href="https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-144364922-1"  type="text/javascript" data-cfasync="false" data-wpfc-render="false" async></script>
			<script type="text/javascript" data-cfasync="false" data-wpfc-render="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<link rel='stylesheet' id='all-css-f7d1920c8e16653110092ad5dce9ac20' href='https://theblackwallsttimes.com/_static/??-eJydkt1uwyAMhV9ohLaq1u1i2qNMDrgprQmIn0Z5+zlJNWVN2iy7QdjH5wOMGy+UqxPWSXrKlamjPGPyoC7SOp0JowxIkFAL72K6iwoV40szRVSZwxJDJctsSMuSnLoIMmWA0MqYWsL/WdMJ7UMrQetyElUw+vcZplaUNT/lHKVFbQCJMewcB57tGARhBaotrKkX3ayN47FnqadkLrzONqJ/ImuOUIOWFqbUuxJW5ZElAQ1Gx/3ZF4diM3edGaNhzTr3l9IGgbNBdJaF8qdffN+MxugKebQiQlCn/qhhKwZFHENP0GuByfnb1D69D1rvGgw8aEBixxMeXQ6KOaBjf5txwRcnV4POrpwhddnVKI1AM6w+vRqmwHowVT0D/JHWdy0ko7pvmLbupqxG4pXLZoBDfj1uJEygj2gea2VEQGU89qZhuzSTXeVt35V+2o/t636zfdsc3nffPiYcGQ==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='empowerlocal_stylesheet-inline-css'>

            .empl-fc-primary{
                color: #000000;
            }
            .empl-fc-secondary{
                color: #232323;
            }
            .empl-fc-tertiary{
                color: #737373;
            }
            .empl-fc-accent{
                color: #E31E26;
            }
            .emp-btn-primary, input.emp-btn-primary{
                background: #E31E26;
            }
</style>
<link rel='stylesheet' id='global-styles-css'  href='https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/' media='1' />
<style id='global-styles-inline-css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;display=swap' media='all' />
<link crossorigin="anonymous" rel="preload" as="style" onload="this.rel='stylesheet'" id="penci-fonts-css" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" type="text/css" media="all">
<noscript><link crossorigin="anonymous" id="penci-fonts-css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"></noscript>
<link rel='stylesheet' id='jetpack-global-styles-frontend-style-css'  href='https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/' media='1' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='monsterinsights-frontend-script-js-extra'>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/theblackwallsttimes.com","hash_tracking":"false","ua":"UA-144364922-1","v4_id":""};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJxlzEEKAjEMQNELmclURN2IR5HYZkprpylNhuLtFXEjLv/iv9HASzWuhq1sMVXFzNbIP/CWqsf7lkrAzoWMAzRR09+a1lSnrLvxD0WRWBioUnla8gqLdBjSQ+usiqTKby0rLv1zBohG8Qte14s7HubZ7U/u/ALc9T3q'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script id='empowerlocal_ads_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_deals_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_campaigns_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_events_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJyVzN0KAiEQBeAXyrXdsLvoUWLQQVx0NH+Sfftki1jyShgYOOfw1cAMSVsUJr62exaM2/cxZ3SEjJMzNK3pVAOTnjJS5sEWbShxdMFXjNZLsGzhEZMvUTYL1O4d+0fLRhmFYHtoT0cpCS6A0dRzv2aUxFeb9d4nHsYOxT/ZrLu7zdfLWSxCiPkNVlKn7A=='></script>
<link rel="https://api.w.org/" href="https://theblackwallsttimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theblackwallsttimes.com/wp-json/wp/v2/posts/57379" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theblackwallsttimes.com/xmlrpc.php?rsd" />

<link rel='shortlink' href='https://wp.me/p8q2YU-eVt' />
<link rel="alternate" type="application/json+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F&#038;format=xml" />

        <script>
            window.abkw = 'news,politics';
        </script><style>#placement_506517_0_i{width:100%;margin:0 auto;}#placement_506518_0_i{width:100%;margin:0 auto;}</style><meta name="generator" content="Site Kit by Google 1.48.1" />	<style type="text/css">
				.penci-recipe-tagged .prt-icon span, .penci-recipe-action-buttons .penci-recipe-button:hover{ background-color:#21842b; }																																																																																															</style>
	<style type="text/css">
																											</style>
<script>var portfolioDataJs = portfolioDataJs || [];</script><style type='text/css'>img#wpstats{display:none}</style>
		<div id="emp-34946" class="amp-video" style="text-align:center;"><script type="text/javascript">
                            var divsize = document.querySelector('#emp-34946').parentNode.clientWidth;
                            var rnd = window.rnd || Math.floor(Math.random()*10e6);
                            var pid506518 = window.pid506518 || rnd;
                            var plc506518 = window.plc506518 || 0;
                            var abkw = window.abkw || '';
                            var absrc = 'https://ads.empowerlocal.co/adserve/;ID=181918;size=0x0;setID=506518;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid506518+';place='+(plc506518++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
                            var _absrc = absrc.split("type=js"); absrc = _absrc[0] + 'type=js;referrer=' + encodeURIComponent(document.location.href) + _absrc[1];
                            document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
                        </script></div><style id="penci-custom-style" type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
    },
    "url": "https:\/\/theblackwallsttimes.com\/",
    "name": "The Black Wall Street Times",
    "description": "Access is the New Civil Right"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Black Wall Street Times",
    "alternateName": "Access is the New Civil Right",
    "url": "https:\/\/theblackwallsttimes.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Twitter permanently bans Rep. Marjorie Taylor Greene\u00a0",
    "description": "Twitter bans U.S. Rep. Marjorie Taylor Greene from its social media platform permanently. The decision comes&hellip;",
    "datePublished": "2022-01-02",
    "datemodified": "2022-01-02",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2022\/01\/02\/twitter-permanently-bans-rep-marjorie-taylor-greene\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2022\/01\/800-2.jpeg?fit=800%2C533&ssl=1",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-TheBlackWallStreetTimes",
        "name": "The Black Wall Street Times"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Twitter permanently bans Rep. Marjorie Taylor Greene\u00a0",
    "image": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2022\/01\/800-2.jpeg?fit=800%2C533&ssl=1",
    "datePublished": "2022-01-02",
    "datemodified": "2022-01-02",
    "description": "",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2022\/01\/02\/twitter-permanently-bans-rep-marjorie-taylor-greene\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "The Black Wall Street Times"
    }
}</script><!-- There is no amphtml version available for this URL. -->			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" sizes="32x32" />
<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" />
<meta name="msapplication-TileImage" content="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-54217030-32']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-57379 single-format-standard wp-custom-logo elementor-default elementor-kit-40761">
	<a id="close-sidebar-nav" class="header-7"><i class="penci-faicon fa fa-close" ></i></a>
	<nav id="sidebar-nav" class="header-7" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">

					<div id="sidebar-nav-logo">
															<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png" alt="The Black Wall Street Times" /></a>
												</div>
		
					<div class="header-social sidebar-nav-social">
				<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>			</div>
				
		
		<ul id="menu-main-menu" class="menu"><li id="menu-item-47824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li id="menu-item-40827" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li id="menu-item-39304" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-41451" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li id="menu-item-40959" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-41010" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li id="menu-item-30664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li id="menu-item-39303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li id="menu-item-40961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
	<li id="menu-item-51452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51452"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
</ul>
</li>
<li id="menu-item-17980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a></li>
<li id="menu-item-15363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li id="menu-item-52228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li id="menu-item-39301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li id="menu-item-41195" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li id="menu-item-39302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-29359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-41874" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li id="menu-item-40965" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
</ul>	</nav>
<div class="wrapper-boxed header-style-header-7 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar no-social">
	<div class="container">
		<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
										<span class="headline-title">BREAKING NEWS</span>
														<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3500" data-speed="200">
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/04/16/7-year-old-girl-traumatized-after-white-school-staff-member-cuts-her-hair/">7-year-old girl traumatized after White school staff member...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/08/23/karen-slaps-black-man-at-nfl-game-and-finds-out/">Karen slaps Black man at NFL game and...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/16/driver-sentenced-to-110-years-for-accident-caused-by-failed-brakes/">Driver sentenced to 110 years for accident caused...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/02/24/oklahoma-bill-makes-it-illegal-to-photo-or-film-police-dems-vote-yes/">Oklahoma bill makes it illegal to photograph or...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/22/why-the-matrix-resurrections-has-a-new-morpheus/">Why &#8220;The Matrix Resurrections&#8221; has a new Morpheus</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/08/13/the-real-sarah-page-center-for-public-secrets-reveals-full-identity-of-woman-whose-false-allegation-launched-tulsa-race-massacre/">The real Sarah Page: Center for Public Secrets...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/21/truckers-boycott-colorado-after-unfair-sentencing-comparison/">Truckers Boycott Colorado after unfair sentencing comparison</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/02/tate-myre-was-a-hero-during-michigan-high-school-shooting/">Tate Myre was a hero during Michigan high...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/03/pepsi-celebrates-hbcu-bands-with-first-ever-commercial/">Pepsi celebrates HBCU bands with first-ever commercial</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/11/11/parole-board-members-ask-court-to-sanction-ag-oconnor-for-trying-to-delay-and-disrupt-proceedings/">Parole Board members ask Court to sanction AG...</a>
							</div>
											</div>
									</div>
	</div>
</div>		<div class="sticky-wrapper">	<nav id="navigation" class="header-layout-top header-7 menu-style-1 penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
		<div class="container container-fullwidth">
			<div class="button-menu-mobile header-1"><i class="penci-faicon fa fa-bars" ></i></div>
			<ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51452"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
</ul><div id="top-search" class="penci-top-search">
	<a class="search-click"><i class="penci-faicon fa fa-search" ></i></a>
	<div class="show-search">
		<form role="search" method="get" id="searchform" action="https://theblackwallsttimes.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>		<a class="search-click close-search"><i class="penci-faicon fa fa-close" ></i></a>
	</div>
</div>			
							<div class="main-nav-social  penci-social-textcolored">
					<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>				</div>
			
		</div>
	</nav><!-- End Navigation -->
	</div><header id="header" class="penci-header-second header-header-7 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
			<div class="inner-header">
			<div class="container container-fullwidth">
				<div id="logo">
					<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png" alt="The Black Wall Street Times"/></a>									</div>

				
							</div>
		</div>
	</header>
<!-- end #header -->
</div>

	<div class="penci-single-pheader container container-single penci_is_nosidebar container-single-fullwidth hentry">
			
	<div class="header-standard header-classic single-header">
					<div class="penci-standard-cat penci-single-cat"><span class="cat"><a class="penci-cat-name penci-cat-602155106" href="https://theblackwallsttimes.com/category/politics/"  rel="category tag">Politics</a></span></div>
		
		<h1 class="post-title single-post-title entry-title">Twitter permanently bans Rep. Marjorie Taylor Greene </h1>
				<div class="penci-hide-tagupdated">
			<span class="author-italic author vcard">by <a class="url fn n" href="https://theblackwallsttimes.com/author/theblackwallsttimes/">The Black Wall Street Times</a></span>
			<time class="entry-date published" datetime="2022-01-02T14:20:55-05:00">January 2, 2022</time>		</div>
							<div class="post-box-meta-single">
									<span class="author-post byline"><span class="author vcard">by <a class="author-url url fn n" href="https://theblackwallsttimes.com/author/theblackwallsttimes/">The Black Wall Street Times</a></span></span>
													<span><time class="entry-date published" datetime="2022-01-02T14:20:55-05:00">January 2, 2022</time></span>
															</div>
					</div>



						<div class="post-image">
				<a href="https://theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg" data-rel="penci-gallery-image-content">											<img width="800" height="533" src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image jetpack-lazy-image" alt="Marjorie Taylor Greene" loading="lazy" data-attachment-id="57390" data-permalink="https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/800-2-9/" data-orig-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&amp;ssl=1" data-orig-size="800,533" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Marjorie Taylor Greene" data-image-description="" data-image-caption="&lt;p&gt;Rep. Marjorie Taylor Greene, R-Ga., listens during a news conference about the treatment of people being held in the District of Columbia jail who are charged with crimes in the Jan. 6 insurrection, at the Capitol in Washington, Tuesday, Dec. 7, 2021. Twitter on Sunday, Jan. 2, 2022, banned the personal account of Greene for multiple violations of its COVID-19 misinformation policy, according to a statement from the company. (AP Photo/J. Scott Applewhite, File)&lt;/p&gt;
" data-medium-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?w=800&amp;ssl=1 800w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?resize=585%2C390&amp;ssl=1 585w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?resize=263%2C175&amp;ssl=1 263w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/800-2.jpeg?fit=800%2C533&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a><div class="penci-featured-caption">Rep. Marjorie Taylor Greene, R-Ga., listens during a news conference about the treatment of people being held in the District of Columbia jail who are charged with crimes in the Jan. 6 insurrection, at the Capitol in Washington, Tuesday, Dec. 7, 2021. Twitter on Sunday, Jan. 2, 2022, banned the personal account of Greene for multiple violations of its COVID-19 misinformation policy, according to a statement from the company. (AP Photo/J. Scott Applewhite, File)</div>			</div>
			

		</div>

<div class="container container-single penci_is_nosidebar penci-single-smaller-width penci-enable-lightbox">
	<div id="main" class="penci-main-sticky-sidebar">
		<div class="theiaStickySidebar">
											<article id="post-57379" class="post type-post status-publish">

	
						<div class="penci-google-adsense-1">
				<div id="emp-d29b5" class="amp-action" style="text-align:center;">    
                        <script type="text/javascript">
                            var divsize = document.querySelector('#emp-d29b5').parentNode.clientWidth;
                            var rnd = window.rnd || Math.floor(Math.random()*10e6);
                            var pid506517 = window.pid506517 || rnd;
                            var plc506517 = window.plc506517 || 0;
                            var abkw = window.abkw || '';
                            var absrc = 'https://ads.empowerlocal.co/adserve/;ID=181918;size=0x0;setID=506517;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid506517+';place='+(plc506517++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
                            var _absrc = absrc.split("type=js"); absrc = _absrc[0] + 'type=js;referrer=' + encodeURIComponent(document.location.href) + _absrc[1];
                            document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
                        </script></div>			</div>
			
	
		<div class="tags-share-box tags-share-box-top tags-share-box-2_3 tags-share-box-s3">
		<span class="penci-social-share-text">Share</span>		
					<div class="post-share hide-like-count">
				
				<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank"  href="https://www.facebook.com/sharer/sharer.php?u=https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank"  href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Twitter%20permanently%20bans%20Rep.%20Marjorie%20Taylor%20Greene%C2%A0%20-%20https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" target="_blank"  href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F&#038;title=Twitter%20permanently%20bans%20Rep.%20Marjorie%20Taylor%20Greene%C2%A0"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-email" target="_blank"  href="mailto:?subject=Twitter%20permanently%20bans%20Rep.%20Marjorie%20Taylor%20Greene &#038;BODY=https://theblackwallsttimes.com/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a></div>			</div>
			</div>
	<div class="post-entry blockquote-style-2">
		<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
			<p><span style="font-weight: 400;">Twitter bans </span><a href="https://en.wikipedia.org/wiki/Marjorie_Taylor_Greene"><span style="font-weight: 400;">U.S. Rep. Marjorie Taylor Greene</span></a><span style="font-weight: 400;"> from its social media platform permanently. The decision comes days after Greene sent out a culturally incompetent Tweet that criticized the African American holiday of Kwanzaa. </span></p>
<p><span style="font-weight: 400;">The Georgia Republican and QAnon conspiracist received her final strike Sunday for continuously spreading misinformation about COVID-19.</span></p>
<p><span style="font-weight: 400;">Greene violated the </span><a href="https://help.twitter.com/en/rules-and-policies/medical-misinformation-policy"><span style="font-weight: 400;">social media giant’s policy for the fifth time</span></a><span style="font-weight: 400;">, which resulted in her </span><a href="https://twitter.com/mtgreenee"><span style="font-weight: 400;">personal account</span></a><span style="font-weight: 400;">‘s indefinite suspension. </span></p>
<p><span style="font-weight: 400;">On Saturday, Greene took to Twitter, tweeting: “extremely high amounts of Covid vaccine deaths.” </span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-605ec" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-605ec').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-605ec-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><p><span style="font-weight: 400;">The Center for Disease Control and Prevention (CDC) maintains that vaccination against COVID-19 is </span><a href="https://www.cdc.gov/coronavirus/2019-ncov/vaccines/safety/adverse-events.html"><span style="font-weight: 400;">safe and effective</span></a><span style="font-weight: 400;">. The CDC however cautions that “</span><span style="font-weight: 400;">serious adverse events after COVID-19 vaccination are rare but may occur”, and so is the case for most vaccines. </span></p>
<p><span style="font-weight: 400;">The Biden Administration urges tech companies to take stronger actions concerning falsehoods that vaccines against the coronavirus are killing people. </span></p>
<p><span style="font-weight: 400;">“Misinformation poses an imminent and insidious threat to our nation’s health. We must confront misinformation as a nation. Lives are depending on it,” </span><span style="font-weight: 400;">U.S. Surgeon General Vivek Murthy </span><a href="https://apnews.com/article/joe-biden-business-health-media-social-media-73ca875f1d1c04bc69108607d8499e3c"><span style="font-weight: 400;">said last July</span></a><span style="font-weight: 400;">. </span></p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://theblackwallsttimes.com/2021/12/03/john-legend-and-chrissy-teigen-show-covid-vaccinations-are-safe-for-kids/" target="_blank" rel="dofollow" class="IRPP_ruby"><!-- INLINE RELATED POSTS 1/3 //--><style> .IRPP_ruby , .IRPP_ruby .postImageUrl , .IRPP_ruby .centered-text-area { height: 130px; position: relative; } .IRPP_ruby , .IRPP_ruby:hover , .IRPP_ruby:visited , .IRPP_ruby:active { border:0!important; } .IRPP_ruby .clearfix:after { content: ""; display: table; clear: both; } .IRPP_ruby { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #FFFFFF; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_ruby:active , .IRPP_ruby:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #eaeaea; } .IRPP_ruby .postImageUrl { background-position: center; background-size: cover; float: left; margin: 0; padding: 0; width: 31.59%; } .IRPP_ruby .centered-text-area { float: right; width: 65.65%; padding:0; margin:0; } .IRPP_ruby .centered-text { display: table; height: 130px; left: 0; top: 0; padding:0; margin:0; } .IRPP_ruby .IRPP_ruby-content { display: table-cell; margin: 0; padding: 0 74px 0 0px; position: relative; vertical-align: middle; width: 100%; } .IRPP_ruby .ctaText { border-bottom: 0 solid #fff; color: #27AE60; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; } .IRPP_ruby .postTitle { color: #000000; font-size: 16px; font-weight: 600; margin: 0; padding: 0; } .IRPP_ruby .ctaButton { background: url(https://theblackwallsttimes.com/wp-content/plugins/intelly-related-posts-pro/assets/images/next-arrow.png)no-repeat; display: inline-block; height: 130px; width: 54px; } .IRPP_ruby .ctaButton { background-color: #27AE60; margin-left: 10px; position: absolute; right: 0; top: 0; } .IRPP_ruby:after { content: ""; display: block; clear: both; } </style><div class="postImageUrl" style="background-image:url(https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Our-Brown-Boy-Joy-2.jpg?fit=300%2C169&ssl=1);"></div><div class="centered-text-area"><div class="centered-text"><div class="IRPP_ruby-content"><div class="ctaText" style="float:left;">See also</div><div style="clear:both"></div><div class="postTitle" style="float:left;">John Legend and Chrissy Teigen show covid vaccinations are safe for kids</div></div></div><div class="ctaButton"></div></div></a></div><h1><span style="color: #000000;"><strong>Twitter’s Policy </strong></span></h1>
<p><span style="font-weight: 400;">According to Twitter, spreading “false or misleading information regarding the safety or science behind approved or authorized COVID-19 vaccines is a direct violation of </span><a href="https://help.twitter.com/en/rules-and-policies/medical-misinformation-policy"><span style="font-weight: 400;">its policy</span></a><span style="font-weight: 400;">.  </span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-dc9b2" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-dc9b2').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-dc9b2-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><p><span style="font-weight: 400;">In response to the suspension, the Georgia Representative released the following statement: </span><span style="font-weight: 400;">“Social media platforms can’t stop the truth from being spread far and wide. Big Tech can’t stop the truth. Communist Democrats can’t stop the truth. I stand with the truth and the people. We will overcome!”</span></p>
<p><span style="font-weight: 400;">Greene’s account was first suspended from Twitter on January 17, 2021, for tweeting misinformation about the 2020 election results. On July 19 and August 10, 2021, she received suspensions for spreading false information about Covid-19. </span></p>
<p>However, her account was <a href="https://apnews.com/article/conspiracy-theories-marjorie-taylor-greene-1c3a8e6ac7ab9e5e1a7303aeb9f5784a">suspended by mistake</a> last March.</p>
<h1><strong>Greene’s Critiques On Censorship</strong></h1>
<p><span style="font-weight: 400;">Representative Greene remains critical of censoring by social media platforms.  They are “a Communist-style attack on free speech,” she says. Adding, </span><span style="font-weight: 400;">“Twitter, Facebook, and the rest of the Silicon Valley Cartel are working hand in hand with the White House to censor Americans,” she previously said when her account was temporarily suspended in the past. </span><span style="font-weight: 400;">Notably, Greene still has access to her official congressional Twitter account.</span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-c7179" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-c7179').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-c7179-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><p><span style="font-weight: 400;">Greene joins former President Donald J. Trump in Republican elected officials Twitter places permanent bans on. </span></p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://theblackwallsttimes.com/2021/12/21/oklahoma-doctors-issue-public-letter-denouncing-prosecutions-involving-pregnancy-and-allegations-of-drug-use/" target="_blank" rel="dofollow" class="IRPP_ruby"><!-- INLINE RELATED POSTS 2/3 //--><style> .IRPP_ruby , .IRPP_ruby .postImageUrl , .IRPP_ruby .centered-text-area { height: 130px; position: relative; } .IRPP_ruby , .IRPP_ruby:hover , .IRPP_ruby:visited , .IRPP_ruby:active { border:0!important; } .IRPP_ruby .clearfix:after { content: ""; display: table; clear: both; } .IRPP_ruby { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #FFFFFF; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_ruby:active , .IRPP_ruby:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #eaeaea; } .IRPP_ruby .postImageUrl { background-position: center; background-size: cover; float: left; margin: 0; padding: 0; width: 31.59%; } .IRPP_ruby .centered-text-area { float: right; width: 65.65%; padding:0; margin:0; } .IRPP_ruby .centered-text { display: table; height: 130px; left: 0; top: 0; padding:0; margin:0; } .IRPP_ruby .IRPP_ruby-content { display: table-cell; margin: 0; padding: 0 74px 0 0px; position: relative; vertical-align: middle; width: 100%; } .IRPP_ruby .ctaText { border-bottom: 0 solid #fff; color: #27AE60; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; } .IRPP_ruby .postTitle { color: #000000; font-size: 16px; font-weight: 600; margin: 0; padding: 0; } .IRPP_ruby .ctaButton { background: url(https://theblackwallsttimes.com/wp-content/plugins/intelly-related-posts-pro/assets/images/next-arrow.png)no-repeat; display: inline-block; height: 130px; width: 54px; } .IRPP_ruby .ctaButton { background-color: #27AE60; margin-left: 10px; position: absolute; right: 0; top: 0; } .IRPP_ruby:after { content: ""; display: block; clear: both; } </style><div class="postImageUrl" style="background-image:url(https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Untitled-design-10.jpg?fit=300%2C164&ssl=1);"></div><div class="centered-text-area"><div class="centered-text"><div class="IRPP_ruby-content"><div class="ctaText" style="float:left;">See also</div><div style="clear:both"></div><div class="postTitle" style="float:left;">Oklahoma doctors issue public letter denouncing prosecutions involving pregnancy and allegations of drug use</div></div></div><div class="ctaButton"></div></div></a></div><p><span style="font-weight: 400;">Meanwhile, </span><span style="font-weight: 400;">Rep Rand Paul, Rep Jim Banks, Rep Briscoe Cain, Rep Ron Johnson, and Rep Barry Moore have received suspensions for either spreading false information about COVID-19 or the 2020 election results. Notably, all are members of the Republican Party. </span></p>
<h1><strong>Myths and Facts about COVID-19</strong></h1>
<p><span style="font-weight: 400;">For more information about COVID-19 Myths and Facts about COVID-19 Vaccines, </span><a href="https://www.cdc.gov/coronavirus/2019-ncov/vaccines/facts.html"><span style="font-weight: 400;">click here</span></a><span style="font-weight: 400;">.</span></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div>			
			<div class="penci-single-link-pages">
						</div>
			
					</div>
	</div>

			<div class="penci-google-adsense-2">
			
                    <div class="emp-ad-anchor-wrapper" id="emp-0ef28">    
                        <div class="emp-ad-anchor" id="506519" style="text-align:center;"><div id="emp-0ef28" class="emp-ad-anchor-inner" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-0ef28').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-0ef28-size-"+divsize);
                if(divsize >= 728){
                    var plc506519 = window.plc506519 || 0;
                    document.write('<'+'div id="placement_506519_'+plc506519+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506519, [728,90], 'placement_506519_'+opt.place, opt); }, opt: { place: plc506519++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506529 = window.plc506529 || 0;
                    document.write('<'+'div id="placement_506529_'+plc506529+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506529, [320,50], 'placement_506529_'+opt.place, opt); }, opt: { place: plc506529++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div>
                        </div>
                        <span class="emp-ad-anchor-x" onclick="document.getElementById('506519').style.display='none';">
                            x
                        </span>
                    </div>

		</div>
	
		
	
			<div class="post-author">
	<div class="author-img">
		<img alt src="https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=100&#038;d=identicon&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=200&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=100&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=100&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/8c6c5cb9a2be7d4fc537bd01c490ee4b?s=200&#038;d=identicon&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/></noscript>	</div>
	<div class="author-content">
		<h5><a href="https://theblackwallsttimes.com/author/theblackwallsttimes/" title="Posts by The Black Wall Street Times" rel="author">The Black Wall Street Times</a></h5>
		<p>The Black Wall Street Times is a news publication located in Tulsa, Okla. and Atlanta, Ga. At The BWSTimes, we focus on elevating the stories of our beloved Greenwood community, elevating the stories of the Black American experience and speaking truth to power. SignUp for our free newsletter on our home page and follow us on social media to keep up with our latest work.</p>
					<a  target="_blank" class="author-social" href="http://www.bwstimes.com"><i class="penci-faicon fa fa-globe" ></i></a>
							<a  target="_blank" class="author-social" href="http://facebook.com/@BWSTimes"><i class="penci-faicon fa fa-facebook" ></i></a>
									<a  target="_blank" class="author-social" href="http://instagram.com/thebwstimes"><i class="penci-faicon fa fa-instagram" ></i></a>
											<a  target="_blank" class="author-social" href="https://www.linkedin.com/company/bwstimes"><i class="penci-faicon fa fa-linkedin" ></i></a>
									<a  target="_blank" class="author-social" href="https://www.youtube.com/channel/UCZJJEGEW3Mri0ojXV-rVjVg"><i class="penci-faicon fa fa-youtube-play" ></i></a>
							<a class="author-social" href="mailto:nehemiahd.frank@gmail.com"><i class="penci-faicon fa fa-envelope" ></i></a>
			</div>
</div>	
	
		
		
	
	
	
		
			<div class="post-comments no-comment-yet penci-comments-hide-0" id="comments">
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/01/02/twitter-permanently-bans-rep-marjorie-taylor-greene/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&#038;postid=57379&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.5-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=fa3404dd8ea1ec71c85a59cd628de7f41e6e78de#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div> <!-- end comments div -->
		
	
	
	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
				<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
								<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Untitled-design-18-1-e1640802718261.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/29/governor-stitt-loses-federal-appeal-to-block-vaccine-mandate-for-national-guard/" title="Governor Stitt loses federal appeal to block vaccine mandate for National Guard">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/29/governor-stitt-loses-federal-appeal-to-block-vaccine-mandate-for-national-guard/">Governor Stitt loses federal appeal to block vaccine...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-29T13:32:58-05:00">December 29, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Wisc_primary_long_lines_AP-scaled-e1601413409486.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/29/black-voters-approval-rating-for-president-biden-declines/" title="Black voters&#8217; approval rating for President Biden declines">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/29/black-voters-approval-rating-for-president-biden-declines/">Black voters&#8217; approval rating for President Biden declines</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-29T12:38:27-05:00">December 29, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Standridge-e1640727901840.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/28/oklahoma-bill-would-allow-parents-to-ban-books-of-their-choosing-or-receive-compensation/" title="Oklahoma bill would allow parents to ban books of their choosing or receive compensation">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/28/oklahoma-bill-would-allow-parents-to-ban-books-of-their-choosing-or-receive-compensation/">Oklahoma bill would allow parents to ban books...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-28T16:49:06-05:00">December 28, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/stittbooster-e1640717939949.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/28/oklahoma-governor-wont-get-booster-as-state-ranks-1-for-covid-deaths/" title="Oklahoma governor won&#8217;t get booster as state ranks #1 for COVID deaths">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/28/oklahoma-governor-wont-get-booster-as-state-ranks-1-for-covid-deaths/">Oklahoma governor won&#8217;t get booster as state ranks...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-28T14:04:16-05:00">December 28, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Untitled-design-14-1.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/28/republican-senate-candidate-launches-racist-attack-on-kwanzaa/" title="Republican Senate Candidate launches racist attack on Kwanzaa">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/28/republican-senate-candidate-launches-racist-attack-on-kwanzaa/">Republican Senate Candidate launches racist attack on Kwanzaa</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-28T13:25:24-05:00">December 28, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/student-debt-taibbi.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/27/study-forgiving-student-loan-debt-would-increase-black-wealth/" title="Study: forgiving student loan debt would increase Black wealth">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/27/study-forgiving-student-loan-debt-would-increase-black-wealth/">Study: forgiving student loan debt would increase Black...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-27T13:37:41-05:00">December 27, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Untitled-design-13-2-e1640622823470.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/27/survey-finds-a-majority-of-oklahomans-support-clemency-for-julius-jones/" title="Survey finds a majority of Oklahomans support clemency for Julius Jones">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/27/survey-finds-a-majority-of-oklahomans-support-clemency-for-julius-jones/">Survey finds a majority of Oklahomans support clemency...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-27T11:39:12-05:00">December 27, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Untitled-design-12-e1640280409880.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/23/trump-pushes-back-against-candace-owens-the-vaccine-works-but-some-people-arent-taking-it/" title="Trump pushes back against Candace Owens: “The vaccine works, but some people aren’t taking it.”">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/23/trump-pushes-back-against-candace-owens-the-vaccine-works-but-some-people-arent-taking-it/">Trump pushes back against Candace Owens: “The vaccine...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-23T12:31:26-05:00">December 23, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/shutterstock_195716306.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/22/breaking-biden-extends-student-loan-repayment-pause-until-may-1/" title="BREAKING: Biden extends student loan repayment pause until May 1">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/22/breaking-biden-extends-student-loan-repayment-pause-until-may-1/">BREAKING: Biden extends student loan repayment pause until...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-22T14:03:52-05:00">December 22, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/800-2.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/22/pentagon-says-klan-supporters-can-still-serve-in-us-military/" title="Pentagon says Klan supporters can still serve in US military">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/22/pentagon-says-klan-supporters-can-still-serve-in-us-military/">Pentagon says Klan supporters can still serve in...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-22T09:58:30-05:00">December 22, 2021</time></span>
									</div>
		</div></div>		
		
	
	
			<div class="post-pagination">
				<div class="prev-post">
												<a class="penci-post-nav-thumb" href="https://theblackwallsttimes.com/2022/01/01/new-york-city-ushers-in-2022-with-ball-drop-in-times-square/" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/image.jpeg?resize=150%2C150&#038;ssl=1');">
					</a>
										<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="https://theblackwallsttimes.com/2022/01/01/new-york-city-ushers-in-2022-with-ball-drop-in-times-square/">
					<div class="pagi-text">
						<h5 class="prev-title">New York City ushers in 2022 with ball drop in Times Square</h5>
					</div>
				</a>
			</div>
		</div>
	
	</div>	
		
		
		
	
</article>					</div>
	</div>
	<!-- END CONTAINER -->
</div>

<div class="clear-footer"></div>


		<div id="widget-area">
			<div class="container">
									<div class="footer-widget-wrapper footer-widget-style-10">
						<aside id="pages-18" class="widget widget_pages"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Pages</span></h4>
			<ul>
				<li class="page_item page-item-53674"><a href="https://theblackwallsttimes.com/advertising/">Advertising</a></li>
<li class="page_item page-item-46879"><a href="https://theblackwallsttimes.com/donate/">DONATE</a></li>
<li class="page_item page-item-46613"><a href="https://theblackwallsttimes.com/freelance-opinion-piece-submissions/">Freelance &#038; Opinion Piece Submissions</a></li>
<li class="page_item page-item-46678"><a href="https://theblackwallsttimes.com/">Home Page</a></li>
<li class="page_item page-item-56959"><a href="https://theblackwallsttimes.com/careers/">Job &#038; Career Opportunities</a></li>
<li class="page_item page-item-51443"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
<li class="page_item page-item-51194"><a href="https://theblackwallsttimes.com/ownership-funding/">Ownership &#038; Funding</a></li>
<li class="page_item page-item-51178"><a href="https://theblackwallsttimes.com/publishing-policies/">Publishing Policies</a></li>
<li class="page_item page-item-45157"><a href="https://theblackwallsttimes.com/team/">TEAM</a></li>
<li class="page_item page-item-41837"><a href="https://theblackwallsttimes.com/the-victory-of-greenwood-series/">The Victory of Greenwood Series</a></li>
			</ul>

			</aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-10 last">
						<aside id="penci_related_news_widget-4" class="widget penci_related_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Related Post</span></h4>					<ul id="penci-relatedwg-7376" class="side-newsfeed">
													<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2022/01/image.jpeg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2022/01/01/new-york-city-ushers-in-2022-with-ball-drop-in-times-square/" title="New York City ushers in 2022 with ball drop in Times Square"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2022/01/01/new-york-city-ushers-in-2022-with-ball-drop-in-times-square/" rel="bookmark" title="New York City ushers in 2022 with ball drop in Times Square">
												New York City ushers in 2022 with ball drop in Times Square											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2022-01-01T09:44:36-05:00">January 1, 2022</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Photos-of-the-year-1-e1640894769890.jpg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/31/the-black-wall-street-times-2021-photos-of-the-year/" title="The Black Wall Street Times&#8217; 2021 photos of the year"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2021/12/31/the-black-wall-street-times-2021-photos-of-the-year/" rel="bookmark" title="The Black Wall Street Times&#8217; 2021 photos of the year">
												The Black Wall Street Times&#8217; 2021 photos of the year											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2021-12-31T10:56:35-05:00">December 31, 2021</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/ed3c6df0b02ed51f434d.jpeg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/30/detroit-re-establishes-the-states-first-historically-black-college/" title="Detroit re-establishes the state&#8217;s first Historically Black College"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2021/12/30/detroit-re-establishes-the-states-first-historically-black-college/" rel="bookmark" title="Detroit re-establishes the state&#8217;s first Historically Black College">
												Detroit re-establishes the state&#8217;s first Historically Black College											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2021-12-30T12:20:39-05:00">December 30, 2021</time></span>
																			</div>
								</div>
							</li>
												</ul>

				</aside>					</div>
							</div>
		</div>


	<div class="footer-subscribe">
			</div>

<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
	<div class="container">
					<div class="footer-socials-section">
				<ul class="footer-socials">
											<li><a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i><span>Facebook</span></a></li>
																<li><a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i><span>Twitter</span></a></li>
																<li><a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i><span>Instagram</span></a></li>
																<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i><span>Pinterest</span></a></li>
																<li><a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i><span>Linkedin</span></a></li>
																															<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i><span>Youtube</span></a></li>
																																																																																																																																																																	<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i><span>tiktok</span></a></li>
									</ul>
			</div>
											<div class="penci-go-to-top-floating"><i class="penci-faicon fa fa-angle-up" ></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>
<div
				class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_8 module_id_8  "
				
			data-id="8"
			data-render-id="0"
			data-tracking="disabled"
			
				data-intro="no_animation"
				data-outro="no_animation"
				data-overlay-close="1"
				data-close-delay="false"
				
				style="opacity: 0;"
			><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-optin hustle-optin--default"><button class="hustle-button-icon hustle-button-close has-background">
			<span class="hustle-icon-close" aria-hidden="true"></span>
			<span class="hustle-screen-reader">Close this module</span>
		</button><div class="hustle-success" data-close-delay="false" style="display: none;"><span class="hustle-icon-check" aria-hidden="true"></span><div class="hustle-success-content"></div></div><div class="hustle-layout"><div class="hustle-layout-body"><div class="hustle-layout-content hustle-layout-position--above"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://theblackwallsttimes.com/wp-content/uploads/2020/12/BWSTimes-Bubble-Logo-.png" alt="" class="hustle-image-position--centercenter" /></div><div class="hustle-content"><div class="hustle-content-wrap"><div class="hustle-group-title"><span class="hustle-title">THE BLACK WALL STREET TIMES</span></div><div class="hustle-group-content"><p style="text-align: center">Support Black-owned media, learn our stories and diverse perspectives by subscribing below.</p></div></div></div></div><form class="hustle-layout-form" novalidate="novalidate"><div class="hustle-form hustle-form-inline"><div class="hustle-form-fields hustle-proximity-separated"><div class="hustle-field hustle-field-required "><label for="hustle-field-email-module-8" id="hustle-field-email-module-8-label" class="hustle-screen-reader">Email</label><input id="hustle-field-email-module-8" type="email" class="hustle-input " name="email" value="" aria-labelledby="hustle-field-email-module-8-label" data-validate="1" data-required-error="Email field is required." data-validation-error="Please enter a valid email." /><span class="hustle-input-label" aria-hidden="true" style="flex-flow: row nowrap;"><span>Enter your email address</span></span></div><button class="hustle-button hustle-button-submit " aria-live="polite" data-loading-text="Form is being submitted, please wait a bit."><span class="hustle-button-text">Subscribe</span><span class="hustle-icon-loader hustle-loading-icon" aria-hidden="true"></span></button></div></div><input type="hidden" name="hustle_module_id" value="8"><input type="hidden" name="post_id" value="57379"><div class="hustle-error-message" style="display: none;" data-default-error="Something went wrong, please try again."></div></form></div></div></div></div></div><!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202252'></script>
	<div style="display:none">
	<div class="grofile-hash-map-8c6c5cb9a2be7d4fc537bd01c490ee4b">
	</div>
	</div>
<link rel='stylesheet' id='all-css-767f1cada21182c5310a3012f7cd588f' href='https://theblackwallsttimes.com/_static/??-eJytzF0KgzAQBOALNVnE1p+H0rNEGzQQs4uzIdc3CPYC9XGGma+ImTmpT0oS8xISqPD+ld0DRliykAO8gtYMjd7kQDN+KdQz7BaSreWj/IctkScX79JYtEI3Yefiwj7bu+na1/jshr49AK1het0=' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='hustle-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A700%2Cregular%2C500%2C400&#038;display=swap' media='all' />
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJx9j90KwjAMhV/ILf7AmBfio0iXBZeuS2ubbuztnTgYKHp1QjjfSc4UCvSiJArB5TtLAksaDPZwY0FoMrsWQufVyyrlwFLatJu+UfSN89gnaDkp2G1RGOHBKPtfZCBBLiKNTNMLtI9McS7JpDkwYWei/rn7Sb+n1bzUcLmltMVC5uWzSGvidbgcqlNdn6vjvn4CMmVmtw=='></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script>
<script id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/js/hustle-ui.min.js?m=1635946873'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script id='hustle_front-js-extra'>
var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"0","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["scroll"]},"animation_in":"no_animation","animation_out":"no_animation","after_close":"no_show_all","expiration":365,"expiration_unit":"days","on_submit":"close","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"no_show_all","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"10\/23\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"10\/29\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5","after_close_trigger":["click_close_icon"]},"module_id":"8","blog_id":"0","module_name":"The Weekly | The Black Wall Street Times","module_type":"popup","active":"1","module_mode":"optin"}];
var incOpt = {"is_admin":"","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene&text=Twitter%20permanently%20bans%20Rep.%20Marjorie%20Taylor%20Greene%C2%A0","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene","email":"mailto:?subject=Twitter%20permanently%20bans%20Rep.%20Marjorie%20Taylor%20Greene%C2%A0&body=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene"},"ajaxurl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","page_id":"57379","page_slug":"2022-01-02-twitter-permanently-bans-rep-marjorie-taylor-greene","is_upfront":"","script_delay":"3000"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/js/front.min.js?m=1635946873'></script>
<script src='https://secure.gravatar.com/js/gprofiles.js' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script id='main-scripts-js-extra'>
var ajax_var_more = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"cead5e85b4","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_like_post-js-extra'>
var ajax_var = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"cead5e85b4","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_archive_more_scroll-js-extra'>
var SOLEDADLOCALIZE = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"cead5e85b4","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='penci_rateyo-js-extra'>
var PENCI = {"ajaxUrl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"cead5e85b4"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJytUdtOxCAQ/SEpXuImfTB+yobCpJ0uwyAMberXS9Majdm1PvgEzLnBYY7KchAIoqMvPYasR5Bo7EUTu+Ih6zn2iQduxnw3f7FlAKpgZg/OOD1m7bHLKtuEURrCcMgn8wdS5CzK4wUOmSbZASdQxAnUKtsVGKwvrnIrxzJRVasE0S9XLnmzAnQ9SI2DNWV12nZqAw5c9vU8QXCctCnCZETQfiLKm/dFIZm+ZjnMorE6pQxWkIPiLkOaIP1/zLfBDfMIwWLty2KE9d3jW4G0NMkILPxLgz91VYChP2+DKz9Tj0AduN3ylV4eTk/t833bnh4/AIQWAR8='></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=57379&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=fa3404dd8ea1ec71c85a59cd628de7f41e6e78de#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=57379&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=fa3404dd8ea1ec71c85a59cd628de7f41e6e78de#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2022%2F01%2F02%2Ftwitter-permanently-bans-rep-marjorie-taylor-greene%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202252.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.5-a.3',blog:'124418680',post:'57379',tz:'-5',srv:'theblackwallsttimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '124418680', '57379' ]);
</script>
<script type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script>
	<style type="text/css" id="hustle-module-8-0-styles" class="hustle-module-styles hustle-module-styles-8">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</style>

<amp-ad width=728 height=90 type="adbutler" data-account="181918" data-zone=""> </amp-ad>

</body>
</html>