<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg">
		<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times RSS Feed" href="https://theblackwallsttimes.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="The Black Wall Street Times Atom Feed" href="https://theblackwallsttimes.com/feed/atom/" />
	<link rel="pingback" href="https://theblackwallsttimes.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://theblackwallsttimes.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	<link rel='preconnect' href='https://fonts.googleapis.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<meta http-equiv='x-dns-prefetch-control' content='on'>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='preload' as='image' href='https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png' type='image/png'>
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/fontawesome-webfont.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/icomoon.woff' type='font/woff' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/themes/soledad/fonts/weathericons.woff2' type='font/woff2' crossorigin='anonymous' />
<link rel='preload' as='font' href='https://theblackwallsttimes.com/wp-content/plugins/penci-recipe/fonts/ficon.woff2' type='image/woff2' crossorigin='anonymous'>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Merriweather:r:latin,latin-ext","Merriweather:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://theblackwallsttimes.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css"></style>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<script>window._wca = window._wca || [];</script>

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.1.2 (Yoast SEO v17.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>VP Kamala Harris Checks Charlamagne Tha God</title>
	<meta name="description" content="Charlamagne Tha God tried VP Kamala Harris in an interview, asking, &quot;So, who&#039;s the real president of this country? Is it Joe Manchin or Joe Biden, Madame Vice President?&quot;" />
	<link rel="canonical" href="https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="VP Kamala Harris Checks Charlamagne Tha God" />
	<meta property="og:description" content="Charlamagne Tha God tried VP Kamala Harris in an interview, asking, &quot;So, who&#039;s the real president of this country? Is it Joe Manchin or Joe Biden, Madame Vice President?&quot;" />
	<meta property="og:url" content="https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/" />
	<meta property="og:site_name" content="The Black Wall Street Times" />
	<meta property="article:publisher" content="https://www.facebook.com/BWSTimes" />
	<meta property="article:author" content="https://www.facebook.com/NehemiahDarnellFrank" />
	<meta property="article:published_time" content="2021-12-18T20:01:22+00:00" />
	<meta property="og:image" content="https://theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg" />
	<meta property="og:image:width" content="1600" />
	<meta property="og:image:height" content="900" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:description" content="Charlamagne Tha God tried VP Kamala Harris in an interview, asking, &quot;So, who&#039;s the real president of this country? Is it Joe Manchin or Joe Biden, Madame Vice President?&quot;" />
	<meta name="twitter:creator" content="@TheBWSTimes" />
	<meta name="twitter:site" content="@TheBWSTimes" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Nehemiah Frank, Founder &amp; Editor-in-Chief" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://theblackwallsttimes.com/#website","url":"https://theblackwallsttimes.com/","name":"The Black Wall Street Times","description":"Access is the New Civil Right","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://theblackwallsttimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1600%2C900&ssl=1","contentUrl":"https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1600%2C900&ssl=1","width":1600,"height":900,"caption":"Charlamagne Tha God (left); U.S. Vice President Kamala Harris"},{"@type":"WebPage","@id":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#webpage","url":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/","name":"VP Kamala Harris Checks Charlamagne Tha God","isPartOf":{"@id":"https://theblackwallsttimes.com/#website"},"primaryImageOfPage":{"@id":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#primaryimage"},"datePublished":"2021-12-18T20:01:22+00:00","dateModified":"2021-12-18T20:01:22+00:00","author":{"@id":"https://theblackwallsttimes.com/#/schema/person/093c1d8f00fbb0119f10967fe385c40c"},"description":"Charlamagne Tha God tried VP Kamala Harris in an interview, asking, \"So, who's the real president of this country? Is it Joe Manchin or Joe Biden, Madame Vice President?\"","breadcrumb":{"@id":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/"]}]},{"@type":"BreadcrumbList","@id":"https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://theblackwallsttimes.com/"},{"@type":"ListItem","position":2,"name":"VP Kamala Harris Checks Charlamagne Tha God"}]},{"@type":"Person","@id":"https://theblackwallsttimes.com/#/schema/person/093c1d8f00fbb0119f10967fe385c40c","name":"Nehemiah Frank, Founder &amp; Editor-in-Chief","image":{"@type":"ImageObject","@id":"https://theblackwallsttimes.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=96&d=identicon&r=g","caption":"Nehemiah Frank, Founder &amp; Editor-in-Chief"},"description":"Nehemiah D. Frank is the founder &amp; editor-in-chief of The Black Wall Street Times and is a descendant of the historic Greenwood Community, dubbed the Black Wall Street. Frank's work appears in TIME Magazine, Education Post and Tulsa People and various other publications. He attended Harold Washington College and Oklahoma State University, earning a degree in political science. Frank is a formal teacher and assistant principal and cares about equity and diversity in education. He gave a TED Talk about education in 2018. He is a founding delegate for the National Parents Union and serves on various boards, community and national projects.","sameAs":["https://www.facebook.com/NehemiahDarnellFrank","nehemiahdfrank","https://www.linkedin.com/in/nehemiahdfrank/"],"url":"https://theblackwallsttimes.com/author/nfran017/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Feed" href="https://theblackwallsttimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; Comments Feed" href="https://theblackwallsttimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Black Wall Street Times &raquo; VP Kamala Harris Checks Charlamagne Tha God Comments Feed" href="https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.1.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-144364922-1"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<link rel='stylesheet' id='all-css-c70ca630a1f935e0db5ce5db3993e725' href='https://theblackwallsttimes.com/_static/??-eJydlNtuwyAMhl9ohK7bOvVi2qNMDrgpLcQIyKK8/ZyDpjRJD+lNhA//B9gOtReKyoRlkt5WhSmjPGHyoM7Ska4sRhnQQkItPMU0sTIV40s9RxQVmzmGQuaVsVrmltRZWJMHCI2MqbH4nDQd0V2VWmioSqIIRl/uYUplK81XOUXpUBtAyxhWjg3PcgzCYgGqyZwp76o5NrbHmunRaiJFzmFQKNviQoEXTtFdMw53rtVgi18sNYUobpbsWfjDUIgRufWceYHt6/084JpyOoDWnPm7eNpuHjhGFjVo6WDegklKe4YDhwTUGImH6T37zDZLvVsQGo45okdSawT2BtFK7qTf7MO0GLXRRVvLiBDUsduqX4o+Ig6hI+i1wER++MVvngedpxoDTxBYseXnIFLFvYwSdN/gccIPO1eDTpQvkFrvapRGsAuszr0apsB5MEW5APwPra9aSEa1bZiXboisRiI/GmkB2PvX40aBGfQazWOpjAiojMdO1C/vzWSbOazb1G/39bp7239s9vvd9g+3d5Fq' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='woocommerce-layout-inline-css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<style id='empowerlocal_stylesheet-inline-css'>

            .empl-fc-primary{
                color: #000000;
            }
            .empl-fc-secondary{
                color: #232323;
            }
            .empl-fc-tertiary{
                color: #737373;
            }
            .empl-fc-accent{
                color: #E31E26;
            }
            .emp-btn-primary, input.emp-btn-primary{
                background: #E31E26;
            }
</style>
<link rel='stylesheet' id='only screen and (max-width: 768px)-css-bcbe9a02faa4dc3655f7d2135e416e8a' href='https://theblackwallsttimes.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?m=1613517092' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='global-styles-css'  href='https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/' media='1' />
<style id='global-styles-inline-css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;display=swap' media='all' />
<link rel='stylesheet' id='woocommerce-inline-css'  href='https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/' media='all' />
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link crossorigin="anonymous" rel="preload" as="style" onload="this.rel='stylesheet'" id="penci-fonts-css" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap" type="text/css" media="all">
<noscript><link crossorigin="anonymous" id="penci-fonts-css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLora%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif+Caption%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap"></noscript>
<link rel='stylesheet' id='wp-calypso-bridge-masterbar-css'  href='https://theblackwallsttimes.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/wc-calypso-bridge/store-on-wpcom/assets/css/masterbar.css' media='all' />
<link rel='stylesheet' id='jetpack-global-styles-frontend-style-css'  href='https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/' media='1' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='monsterinsights-frontend-script-js-extra'>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/theblackwallsttimes.com","hash_tracking":"false","ua":"UA-144364922-1","v4_id":""};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJxlzE0KAjEMQOELmYk/MNSFeBSJbaa0dprSZCjeXhE34vIt3jcaeKnG1bCVLaaqmNka+QfeUvV431IJ2LmQcYAmavpb05rqlHU3/qEoEgsDVSpPS15hkQ5DemidVZFU+a1lxaV/zgDRKH7B63o5zCfnzvNx717dfD3/'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1605690366'></script>
<script defer src='https://stats.wp.com/s-202150.js' id='woocommerce-analytics-js'></script>
<script id='empowerlocal_ads_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_deals_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_campaigns_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_events_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='empowerlocal_js-js-extra'>
var empowerlocal_ajax = {"ajax_url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJyVzNEKgzAMheEXWs02UbwZe5QRapBKm5Smzte3OBgyd9PL/Cd8azRWOBNniH6ZHCuQp1BuSSYmAVSlrDArRJzI5ISsLjthbYLjZtbL+ocIUVZKXix6c4dEKkuypIDjTh33V2m1zEjoz9BeaymLIaKb+Mx9l1qS3uXt7H1yNXYYfsliPcPj1rdde+27YdgASFaxCg=='></script>
<link rel="https://api.w.org/" href="https://theblackwallsttimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theblackwallsttimes.com/wp-json/wp/v2/posts/56844" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theblackwallsttimes.com/xmlrpc.php?rsd" />

<link rel='shortlink' href='https://wp.me/p8q2YU-eMQ' />
<link rel="alternate" type="application/json+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theblackwallsttimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F&#038;format=xml" />

        <script>
            window.abkw = 'news,politics';
        </script><style>#placement_506517_0_i{width:100%;margin:0 auto;}#placement_506518_0_i{width:100%;margin:0 auto;}</style><meta name="generator" content="Site Kit by Google 1.47.0" />	<style type="text/css">
				.penci-recipe-tagged .prt-icon span, .penci-recipe-action-buttons .penci-recipe-button:hover{ background-color:#21842b; }																																																																																															</style>
	<style type="text/css">
																											</style>
<script>var portfolioDataJs = portfolioDataJs || [];</script><style type='text/css'>img#wpstats{display:none}</style>
		<div id="emp-5c86f" class="amp-video" style="text-align:center;"><script type="text/javascript">
                            var divsize = document.querySelector('#emp-5c86f').parentNode.clientWidth;
                            var rnd = window.rnd || Math.floor(Math.random()*10e6);
                            var pid506518 = window.pid506518 || rnd;
                            var plc506518 = window.plc506518 || 0;
                            var abkw = window.abkw || '';
                            var absrc = 'https://ads.empowerlocal.co/adserve/;ID=181918;size=0x0;setID=506518;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid506518+';place='+(plc506518++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
                            var _absrc = absrc.split("type=js"); absrc = _absrc[0] + 'type=js;referrer=' + encodeURIComponent(document.location.href) + _absrc[1];
                            document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
                        </script></div><style id="penci-custom-style" type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
    },
    "url": "https:\/\/theblackwallsttimes.com\/",
    "name": "The Black Wall Street Times",
    "description": "Access is the New Civil Right"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Black Wall Street Times",
    "alternateName": "Access is the New Civil Right",
    "url": "https:\/\/theblackwallsttimes.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "VP Kamala Harris Checks Charlamagne Tha God",
    "description": "Charlamagne Tha God tried VP Kamala Harris in an interview, asking, &#8220;So, who&#8217;s the real president&hellip;",
    "datePublished": "2021-12-18",
    "datemodified": "2021-12-18",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2021\/12\/18\/vp-kamala-harris-checks-charlamagne-tha-god\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/12\/Warnock-2.jpg?fit=1600%2C900&ssl=1",
        "width": 1600,
        "height": 900
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-NehemiahFrankFounderampEditor-in-Chief",
        "name": "Nehemiah Frank, Founder &amp; Editor-in-Chief"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "VP Kamala Harris Checks Charlamagne Tha God",
    "image": "https:\/\/i0.wp.com\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/12\/Warnock-2.jpg?fit=1600%2C900&ssl=1",
    "datePublished": "2021-12-18",
    "datemodified": "2021-12-18",
    "description": "",
    "mainEntityOfPage": "https:\/\/theblackwallsttimes.com\/2021\/12\/18\/vp-kamala-harris-checks-charlamagne-tha-god\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Black Wall Street Times",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/theblackwallsttimes.com\/wp-content\/uploads\/2021\/03\/The-Black-Wall-Street-Times-3-4-e1615249929580.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Nehemiah Frank, Founder &amp; Editor-in-Chief"
    }
}</script>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '402584430987857', {}, {
    "agent": "wordpress-5.8.2-3.0.6"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=402584430987857&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<!-- There is no amphtml version available for this URL. -->			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" sizes="32x32" />
<link rel="icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" />
<meta name="msapplication-TileImage" content="https://theblackwallsttimes.com/wp-content/uploads/2018/12/Black-Wall-Street-Times-Logo.jpg" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-54217030-32']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-56844 single-format-standard wp-custom-logo theme-soledad woocommerce-no-js elementor-beta elementor-default elementor-kit-40761">
	<a id="close-sidebar-nav" class="header-7"><i class="penci-faicon fa fa-close" ></i></a>
	<nav id="sidebar-nav" class="header-7" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">

					<div id="sidebar-nav-logo">
															<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png" alt="The Black Wall Street Times" /></a>
												</div>
		
					<div class="header-social sidebar-nav-social">
				<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>			</div>
				
		
		<ul id="menu-main-menu" class="menu"><li id="menu-item-47824" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li id="menu-item-40827" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li id="menu-item-39304" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-41451" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li id="menu-item-40959" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-41010" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li id="menu-item-30664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li id="menu-item-39303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li id="menu-item-40961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
	<li id="menu-item-51452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51452"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
</ul>
</li>
<li id="menu-item-17980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a></li>
<li id="menu-item-15363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li id="menu-item-39301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li id="menu-item-41195" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li id="menu-item-52228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li id="menu-item-53683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53683"><a href="https://theblackwallsttimes.com/advertising/">Advertising</a></li>
<li id="menu-item-39302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-29359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-41874" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li id="menu-item-40965" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
</ul>	</nav>
<div class="wrapper-boxed header-style-header-7 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar no-social">
	<div class="container">
		<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
										<span class="headline-title">BREAKING NEWS</span>
														<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3500" data-speed="200">
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/04/16/7-year-old-girl-traumatized-after-white-school-staff-member-cuts-her-hair/">7-year-old girl traumatized after White school staff member...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/08/23/karen-slaps-black-man-at-nfl-game-and-finds-out/">Karen slaps Black man at NFL game and...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/02/24/oklahoma-bill-makes-it-illegal-to-photo-or-film-police-dems-vote-yes/">Oklahoma bill makes it illegal to photograph or...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/08/13/the-real-sarah-page-center-for-public-secrets-reveals-full-identity-of-woman-whose-false-allegation-launched-tulsa-race-massacre/">The real Sarah Page: Center for Public Secrets...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/10/27/why-racist-mass-murderer-dylann-roof-should-not-be-executed/">Why racist mass murderer Dylann Roof should NOT...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/02/tate-myre-was-a-hero-during-michigan-high-school-shooting/">Tate Myre was a hero during Michigan high...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/07/black-11-year-old-strip-searched-locked-in-holding-cell-at-school-by-teacher/">Black 11-year-old strip-searched, locked in holding cell at...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/01/michigan-teen-charged-with-terrorism-as-an-adult-in-high-school-shooting/">Michigan teen charged with terrorism as an adult...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/10/19/jealous-of-colin-powell-trump-throws-shade-after-his-death/">Jealous of Colin Powell, Trump throws shade after...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://theblackwallsttimes.com/2021/12/03/pepsi-celebrates-hbcu-bands-with-first-ever-commercial/">Pepsi celebrates HBCU bands with first-ever commercial</a>
							</div>
											</div>
									</div>
	</div>
</div>		<div class="sticky-wrapper">	<nav id="navigation" class="header-layout-top header-7 menu-style-1 penci-disable-sticky-nav" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
		<div class="container container-fullwidth">
			<div class="button-menu-mobile header-1"><i class="penci-faicon fa fa-bars" ></i></div>
			<ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47824"><a href="https://bwstimes.square.site/">Shop</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40827"><a href="https://theblackwallsttimes.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-39304"><a href="https://theblackwallsttimes.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41451"><a href="https://theblackwallsttimes.com/tag/national-news/">National News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-40959"><a href="https://theblackwallsttimes.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41010"><a href="https://theblackwallsttimes.com/tag/social-justice/">Social Justice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30664"><a href="https://theblackwallsttimes.com/category/opinion/">Op/Eds</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39303"><a href="https://theblackwallsttimes.com/category/editorial/">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40961"><a href="https://theblackwallsttimes.com/category/opinion/">Opinion</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51452"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17980"><a href="https://theblackwallsttimes.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15363"><a href="https://theblackwallsttimes.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39301"><a href="https://theblackwallsttimes.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41195"><a href="https://theblackwallsttimes.com/tag/black-tech-street/">Black Tech Street</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52228"><a href="https://theblackwallsttimes.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53683"><a href="https://theblackwallsttimes.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39302"><a href="https://theblackwallsttimes.com/category/arts-and-culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29359"><a title="Entertainment" href="https://theblackwallsttimes.com/category/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-41874"><a href="https://theblackwallsttimes.com/tag/lgbtq-2/">LGBTQ+</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-40965"><a href="https://theblackwallsttimes.com/tag/poetry/">Poetry</a></li>
</ul>
</li>
</ul><div id="top-search" class="penci-top-search">
	<a class="search-click"><i class="penci-faicon fa fa-search" ></i></a>
	<div class="show-search">
		<form role="search" method="get" id="searchform" action="https://theblackwallsttimes.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>		<a class="search-click close-search"><i class="penci-faicon fa fa-close" ></i></a>
	</div>
</div>			
							<div class="main-nav-social  penci-social-textcolored">
					<div class="inner-header-social">
			<a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
				<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a>
				<a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i></a>
							<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a>
																																	<a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i></a>
	</div>				</div>
			
		</div>
	</nav><!-- End Navigation -->
	</div><header id="header" class="penci-header-second header-header-7 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
			<div class="inner-header">
			<div class="container container-fullwidth">
				<div id="logo">
					<a href="https://theblackwallsttimes.com/"><img src="https://theblackwallsttimes.com/wp-content/uploads/2021/05/BWST_WebsiteHeaderC.png" alt="The Black Wall Street Times"/></a>									</div>

				
							</div>
		</div>
	</header>
<!-- end #header -->
</div>

	<div class="penci-single-pheader container container-single penci_is_nosidebar container-single-fullwidth hentry">
			
	<div class="header-standard header-classic single-header">
					<div class="penci-standard-cat penci-single-cat"><span class="cat"><a class="penci-cat-name penci-cat-602155106" href="https://theblackwallsttimes.com/category/politics/"  rel="category tag">Politics</a></span></div>
		
		<h1 class="post-title single-post-title entry-title">VP Kamala Harris Checks Charlamagne Tha God</h1>
				<div class="penci-hide-tagupdated">
			<span class="author-italic author vcard">by <a class="url fn n" href="https://theblackwallsttimes.com/author/nfran017/">Nehemiah Frank, Founder &#38; Editor-in-Chief</a></span>
			<time class="entry-date published" datetime="2021-12-18T15:01:22-05:00">December 18, 2021</time>		</div>
							<div class="post-box-meta-single">
									<span class="author-post byline"><span class="author vcard">by <a class="author-url url fn n" href="https://theblackwallsttimes.com/author/nfran017/">Nehemiah Frank, Founder &#38; Editor-in-Chief</a></span></span>
													<span><time class="entry-date published" datetime="2021-12-18T15:01:22-05:00">December 18, 2021</time></span>
															</div>
					</div>



						<div class="post-image">
				<a href="https://theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg" data-rel="penci-gallery-image-content">											<img width="1170" height="658" src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1170%2C658&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image jetpack-lazy-image" alt="Charlamagne Tha God; U.S. Vice President Kamala Harris" loading="lazy" data-attachment-id="56851" data-permalink="https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/warnock-2-2/" data-orig-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1600%2C900&amp;ssl=1" data-orig-size="1600,900" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Warnock-2" data-image-description="" data-image-caption="&lt;p&gt;Charlamagne Tha God (left); U.S. Vice President Kamala Harris&lt;/p&gt;
" data-medium-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1024%2C576&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?w=1600&amp;ssl=1 1600w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=1200%2C675&amp;ssl=1 1200w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=1170%2C658&amp;ssl=1 1170w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=585%2C329&amp;ssl=1 585w, https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?resize=600%2C338&amp;ssl=1 600w" data-lazy-sizes="(max-width: 1170px) 100vw, 1170px" data-lazy-src="https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock-2.jpg?fit=1170%2C658&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a><div class="penci-featured-caption">Charlamagne Tha God (left); U.S. Vice President Kamala Harris</div>			</div>
			

		</div>

<div class="container container-single penci_is_nosidebar penci-single-smaller-width penci-enable-lightbox">
	<div id="main" class="penci-main-sticky-sidebar">
		<div class="theiaStickySidebar">
											<article id="post-56844" class="post type-post status-publish">

	
						<div class="penci-google-adsense-1">
				<div id="emp-0b883" class="amp-action" style="text-align:center;">    
                        <script type="text/javascript">
                            var divsize = document.querySelector('#emp-0b883').parentNode.clientWidth;
                            var rnd = window.rnd || Math.floor(Math.random()*10e6);
                            var pid506517 = window.pid506517 || rnd;
                            var plc506517 = window.plc506517 || 0;
                            var abkw = window.abkw || '';
                            var absrc = 'https://ads.empowerlocal.co/adserve/;ID=181918;size=0x0;setID=506517;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid506517+';place='+(plc506517++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
                            var _absrc = absrc.split("type=js"); absrc = _absrc[0] + 'type=js;referrer=' + encodeURIComponent(document.location.href) + _absrc[1];
                            document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
                        </script></div>			</div>
			
	
		<div class="tags-share-box tags-share-box-top tags-share-box-2_3 tags-share-box-s3">
		<span class="penci-social-share-text">Share</span>		
					<div class="post-share hide-like-count">
				
				<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank"  href="https://www.facebook.com/sharer/sharer.php?u=https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank"  href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20VP%20Kamala%20Harris%20Checks%20Charlamagne%20Tha%20God%20-%20https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-linkedin" target="_blank"  href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F&#038;title=VP%20Kamala%20Harris%20Checks%20Charlamagne%20Tha%20God"><i class="penci-faicon fa fa-linkedin" ></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-email" target="_blank"  href="mailto:?subject=VP%20Kamala%20Harris%20Checks%20Charlamagne%20Tha%20God&#038;BODY=https://theblackwallsttimes.com/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a></div>			</div>
			</div>
	<div class="post-entry blockquote-style-2">
		<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
			<p><span style="color: #000000;">Charlamagne Tha God tried VP Kamala Harris in an interview, asking, “So, who’s the real president of this country? Is it Joe Manchin or Joe Biden, Madame Vice President?”</span></p>
<p><span style="color: #000000;">The Vice President didn’t take too kindly to Charlamagne’s sarcastic, journalistic style. </span></p>
<p><span style="color: #000000;">“Come on, Charlamagne. Come on. It’s Joe Biden,” she replied in a disappointing tone. Charlamagne then tried interjecting, but VP Harris doubled down. </span></p>
<p><span style="color: #000000;">“No. No. No. No. No. No! No. No. It’s Joe Biden. It’s Joe Biden! And don’t start talking like a Republican about asking whether or not he’s president. It’s Joe Biden!” she firmly stated. </span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-31354" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-31354').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-31354-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><p><span style="color: #000000;">Charlamagne quickly tried interjecting, asking a follow-up, “Do you think Joe Manchin is a problem?”</span></p>
<h2><strong><span style="color: #000000;">VP Kamala Harris’s Second Firm Response</span></strong></h2>
<blockquote><p><span style="color: #000000;">And it’s Joe Biden, and it’s Joe Biden. I’m Vice President, and my name is Kamala Harris. And the reality is because we are in office we do things like the tax child credit, which is going to reduce Black child poverty by 50-percent — on track to do that. </span></p>
<p> </p>
<p><span style="color: #000000;">We do things that are about saying that our Department of Justice is going to do these investigations and require that we end chokeholds and have body cameras. </span></p>
<p> </p>
<p><span style="color: #000000;">It is the work of saying that we’re going to get lead out of pipes and paint because our babies are suffering because of that. </span></p>
<p> </p>
<p><span style="color: #000000;">It is the work of saying that people who ride public transit deserve the same kind of dignity that anybody else does, so lets improve that system.  </span></p>
<p> </p>
<p><span style="color: #000000;">It is the work of saying that we have got to bring down prescription drug cost because folks who have diebtes should not be dying because they don’t have enough money in their pockets. </span></p>
<p> </p>
<p><span style="color: #000000;">It’s about saying: Black maternal mortality is a real issue that must be treated by everybody, including the White House, as a serious issue. </span></p>
<p> </p>
<p><span style="color: #000000;">Okay!? </span></p>
<p> </p>
<p><span style="color: #000000;">So, let’s. I, I hear the frustration. But lets no deny the impact that we’ve had and agree also that there is a whole lot more work that needs to be done. And it is not easy to do, but we will not give up. And I will not give up.”  </span></p></blockquote>
<p><span style="color: #000000;">Charlamagne commended the Vice President’s vigorous response, saying, “That Kamala Harris, that’s the one I like. That’s the one that was putting the pressure on people in Senate hearings. That’s the one I’d like to see more often out here in these streets.” </span></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">VP Kamala Harris wasn’t about to be publicly disrespected. “And don’t start talking like a Republican about asking whether or not he’s president.” She went in on Charlamagne Tha God and earned mad street cred. Them AKA ladies don’t play. 😂🤣 <a href="https://t.co/din8wNrwXc">pic.twitter.com/din8wNrwXc</a></p>
<p>— Nehemiah D. Frank (@nehemiahdfrank) <a href="https://twitter.com/nehemiahdfrank/status/1472295374404653060?ref_src=twsrc%5Etfw">December 18, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<h2><span style="color: #000000;">Manchin’s Stubbornness?</span></h2>
<p><span style="color: #000000;">Charlamagne took swipes at Senator Joe Manchin, saying he’s “ruining the country” and “blocking progress.” He also suggested that as a result of Manchin’s stubbornness, Black voters may turn against Democrats in the upcoming midterm elections as well as in the 2024 presidential race. </span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-ce20a" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-ce20a').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-ce20a-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><p><span style="color: #000000;">Their interview comes days after Democrats in Congress have expressed frustration over Manchin’s hesitancy to back the $2 trillion social spending and climate bill by the end of 2021. </span></p>
<p><span style="color: #000000;">VP Harris was asked why Manchin “is allowed to constantly hold up Biden’s agenda,” to which she responded that “every vote counts”, adding, “we have to listen to the voices who represent their districts.”</span></p>
<p><span style="color: #000000;">Harris later asserted that it is not just Democrats who are impeding Democratic priorities. </span></p>
<p><span style="color: #000000;">“Here’s the thing, though. I think it’s a mistake to try and think about this only through the lens of Democrats versus Democrats when the fact is Republicans are consistently and unanimously standing in the way of progress.”</span></p>
<div><div class="penci-custom-html-inside-content"><div id="emp-ed57a" class="emp-ad" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-ed57a').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-ed57a-size-"+divsize);
                if(divsize >= 970){
                    var plc506528 = window.plc506528 || 0;
                    document.write('<'+'div id="placement_506528_'+plc506528+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506528, [970,90], 'placement_506528_'+opt.place, opt); }, opt: { place: plc506528++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506523 = window.plc506523 || 0;
                    document.write('<'+'div id="placement_506523_'+plc506523+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506523, [300,250], 'placement_506523_'+opt.place, opt); }, opt: { place: plc506523++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div></div></div><h2><strong><span style="color: #000000;">Saving Our Democracy</span></strong></h2>
<p><span style="color: #000000;">“Right now, we are debating whether democracies actually can survive or is autocracy better, which is basically one person or one group telling everybody what they should do,” VP Harris said. “This is what’s at stake right now for America. And you can tell I’m a bit frustrated — more than that, actually — that people are making this into a partisan issue instead of stepping up to say save our democracy.” </span></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div><div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://theblackwallsttimes.com/2021/12/03/sheriffs-deputy-jason-meade-faces-murder-reckless-homicide-charges/" target="_blank" rel="dofollow" class="IRPP_ruby"><!-- INLINE RELATED POSTS 1/3 //--><style> .IRPP_ruby , .IRPP_ruby .postImageUrl , .IRPP_ruby .centered-text-area { height: 130px; position: relative; } .IRPP_ruby , .IRPP_ruby:hover , .IRPP_ruby:visited , .IRPP_ruby:active { border:0!important; } .IRPP_ruby .clearfix:after { content: ""; display: table; clear: both; } .IRPP_ruby { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #FFFFFF; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_ruby:active , .IRPP_ruby:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #eaeaea; } .IRPP_ruby .postImageUrl { background-position: center; background-size: cover; float: left; margin: 0; padding: 0; width: 31.59%; } .IRPP_ruby .centered-text-area { float: right; width: 65.65%; padding:0; margin:0; } .IRPP_ruby .centered-text { display: table; height: 130px; left: 0; top: 0; padding:0; margin:0; } .IRPP_ruby .IRPP_ruby-content { display: table-cell; margin: 0; padding: 0 74px 0 0px; position: relative; vertical-align: middle; width: 100%; } .IRPP_ruby .ctaText { border-bottom: 0 solid #fff; color: #27AE60; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; } .IRPP_ruby .postTitle { color: #000000; font-size: 16px; font-weight: 600; margin: 0; padding: 0; } .IRPP_ruby .ctaButton { background: url(https://theblackwallsttimes.com/wp-content/plugins/intelly-related-posts-pro/assets/images/next-arrow.png)no-repeat; display: inline-block; height: 130px; width: 54px; } .IRPP_ruby .ctaButton { background-color: #27AE60; margin-left: 10px; position: absolute; right: 0; top: 0; } .IRPP_ruby:after { content: ""; display: block; clear: both; } </style><div class="postImageUrl" style="background-image:url(https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/e7c657a7-c2f5-44ae-bbea-54dbd58a2b2b_1920x1080.jpg?fit=300%2C169&ssl=1);"></div><div class="centered-text-area"><div class="centered-text"><div class="IRPP_ruby-content"><div class="ctaText" style="float:left;">See also</div><div style="clear:both"></div><div class="postTitle" style="float:left;">Sheriff's Deputy Jason Meade faces murder reckless homicide charges</div></div></div><div class="ctaButton"></div></div></a></div>			
			<div class="penci-single-link-pages">
						</div>
			
					</div>
	</div>

			<div class="penci-google-adsense-2">
			
                    <div class="emp-ad-anchor-wrapper" id="emp-f6571">    
                        <div class="emp-ad-anchor" id="506519" style="text-align:center;"><div id="emp-f6571" class="emp-ad-anchor-inner" style="text-align:center;"><script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://ads.empowerlocal.co/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
                <script type="text/javascript">
                var divsize = document.querySelector('#emp-f6571').parentNode.clientWidth;
                var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
                var abkw = window.abkw || '';
                console.log("emp-f6571-size-"+divsize);
                if(divsize >= 728){
                    var plc506519 = window.plc506519 || 0;
                    document.write('<'+'div id="placement_506519_'+plc506519+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506519, [728,90], 'placement_506519_'+opt.place, opt); }, opt: { place: plc506519++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                } else{
                    var plc506529 = window.plc506529 || 0;
                    document.write('<'+'div id="placement_506529_'+plc506529+'"></'+'div>');
                    AdButler.ads.push({handler: function(opt){ AdButler.register(181918, 506529, [320,50], 'placement_506529_'+opt.place, opt); }, opt: { place: plc506529++, keywords: abkw, domain: 'ads.empowerlocal.co', click:'CLICK_MACRO_PLACEHOLDER' }});
                }
                </script></div>
                        </div>
                        <span class="emp-ad-anchor-x" onclick="document.getElementById('506519').style.display='none';">
                            x
                        </span>
                    </div>

		</div>
	
		
	
			<div class="post-author">
	<div class="author-img">
		<img alt src="https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=100&#038;d=identicon&#038;r=g" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=200&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=100&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=100&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/a7f34fb96ded4145cdee142e464d579b?s=200&#038;d=identicon&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/></noscript>	</div>
	<div class="author-content">
		<h5><a href="https://theblackwallsttimes.com/author/nfran017/" title="Posts by Nehemiah Frank, Founder &#038; Editor-in-Chief" rel="author">Nehemiah Frank, Founder &#38; Editor-in-Chief</a></h5>
		<p>Nehemiah D. Frank is the founder &amp; editor-in-chief of The Black Wall Street Times and is a descendant of the historic Greenwood Community, dubbed the Black Wall Street. Frank's work appears in TIME Magazine, Education Post and  Tulsa People and various other publications. He attended Harold Washington College and Oklahoma State University, earning a degree in political science. Frank is a formal teacher and assistant principal and cares about equity and diversity in education. He gave a TED Talk about education in 2018. He is a founding delegate for the National Parents Union and serves on various boards, community and national projects.</p>
							<a  target="_blank" class="author-social" href="http://facebook.com/https://www.facebook.com/NehemiahDarnellFrank"><i class="penci-faicon fa fa-facebook" ></i></a>
									<a  target="_blank" class="author-social" href="http://instagram.com/nehemiahdfrank"><i class="penci-faicon fa fa-instagram" ></i></a>
											<a  target="_blank" class="author-social" href="https://www.linkedin.com/in/nehemiahdfrank/"><i class="penci-faicon fa fa-linkedin" ></i></a>
											<a class="author-social" href="mailto:nehemiah@bwstimes.com"><i class="penci-faicon fa fa-envelope" ></i></a>
			</div>
</div>	
	
		
		
	
	
	
		
			<div class="post-comments no-comment-yet penci-comments-hide-0" id="comments">
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/12/18/vp-kamala-harris-checks-charlamagne-tha-god/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&#038;postid=56844&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.5-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=4204ac9bbcbcfbb3b0f878fd9cf7e3f0346a7f6f#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div> <!-- end comments div -->
		
	
	
	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
				<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
								<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/09/Hannah-Jones-e1631900709731.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/" title="Nikole Hannah-Jones’ warning on democracy in AP interview">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/">Nikole Hannah-Jones’ warning on democracy in AP interview</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-18T12:37:46-05:00">December 18, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/18/proud-boys-supporter-gets-33-months-in-prison-for-threatening-sen-raphael-warnock/" title="Proud Boys&#8217; supporter gets 33 months in prison for threatening Sen. Raphael Warnock">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/18/proud-boys-supporter-gets-33-months-in-prison-for-threatening-sen-raphael-warnock/">Proud Boys&#8217; supporter gets 33 months in prison...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-18T12:11:20-05:00">December 18, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/1.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/17/keechant-sewell-to-become-first-female-nypd-chief-of-police-in-city-history/" title="Keechant Sewell to become first female NYPD chief of police in city history">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/17/keechant-sewell-to-become-first-female-nypd-chief-of-police-in-city-history/">Keechant Sewell to become first female NYPD chief...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-17T19:00:03-05:00">December 17, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Eddie-Faye-Gates-1.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/16/gov-ron-desantis-takes-culture-war-to-classrooms/" title="Gov. Ron DeSantis takes culture war to classrooms">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/16/gov-ron-desantis-takes-culture-war-to-classrooms/">Gov. Ron DeSantis takes culture war to classrooms</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-16T20:08:23-05:00">December 16, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/08/800-2-1.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/15/governor-stitt-seems-to-use-taxpayer-dollars-for-anti-vaccine-mandate-vids/" title="Governor Stitt seems to use taxpayer dollars for anti-vaccine mandate vids">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/15/governor-stitt-seems-to-use-taxpayer-dollars-for-anti-vaccine-mandate-vids/">Governor Stitt seems to use taxpayer dollars for...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-15T07:30:46-05:00">December 15, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/image.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/13/letitia-james-suspends-campaign-for-governor-of-new-york/" title="Letitia James suspends campaign for Governor of New York">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/13/letitia-james-suspends-campaign-for-governor-of-new-york/">Letitia James suspends campaign for Governor of New...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-13T13:27:41-05:00">December 13, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Stacey-Abrams.jpg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/02/stacey-abrams-announces-georgia-gubernatorial-run-with-new-ad/" title="Stacey Abrams announces Georgia gubernatorial run with new ad">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/02/stacey-abrams-announces-georgia-gubernatorial-run-with-new-ad/">Stacey Abrams announces Georgia gubernatorial run with new...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-02T11:51:09-05:00">December 2, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/1000-2.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/01/stacey-abrams-launches-2nd-campaign-for-georgia-governor/" title="Stacey Abrams launches 2nd campaign for Georgia governor">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/01/stacey-abrams-launches-2nd-campaign-for-georgia-governor/">Stacey Abrams launches 2nd campaign for Georgia governor</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-01T16:02:00-05:00">December 1, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/1000-1.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/01/mayor-elect-andre-dickens-to-succeed-mayor-keisha-lance-bottoms-in-atlanta/" title="Mayor-Elect Andre Dickens To Succeed Mayor Keisha Lance Bottoms In Atlanta  ">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/01/mayor-elect-andre-dickens-to-succeed-mayor-keisha-lance-bottoms-in-atlanta/">Mayor-Elect Andre Dickens To Succeed Mayor Keisha Lance...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-01T10:01:06-05:00">December 1, 2021</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/1000.jpeg?resize=585%2C390&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/01/barbados-removes-british-queen-as-head-of-state-elect-first-president/" title="Barbados Removes British Queen as Head of State, Elect First President ">
																			</a>
										<h3><a href="https://theblackwallsttimes.com/2021/12/01/barbados-removes-british-queen-as-head-of-state-elect-first-president/">Barbados Removes British Queen as Head of State,...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2021-12-01T07:45:57-05:00">December 1, 2021</time></span>
									</div>
		</div></div>		
		
	
	
			<div class="post-pagination">
				<div class="prev-post">
												<a class="penci-post-nav-thumb" href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/09/Hannah-Jones-e1631900709731.jpeg?resize=150%2C150&#038;ssl=1');">
					</a>
										<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/">
					<div class="pagi-text">
						<h5 class="prev-title">Nikole Hannah-Jones’ warning on democracy in AP interview</h5>
					</div>
				</a>
			</div>
		</div>
	
	</div>	
		
		
		
	
</article>					</div>
	</div>
	<!-- END CONTAINER -->
</div>

<div class="clear-footer"></div>


		<div id="widget-area">
			<div class="container">
									<div class="footer-widget-wrapper footer-widget-style-10">
						<aside id="pages-18" class="widget widget_pages"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Pages</span></h4>
			<ul>
				<li class="page_item page-item-53674"><a href="https://theblackwallsttimes.com/advertising/">Advertising</a></li>
<li class="page_item page-item-46879"><a href="https://theblackwallsttimes.com/donate/">DONATE</a></li>
<li class="page_item page-item-46678"><a href="https://theblackwallsttimes.com/">Home Page</a></li>
<li class="page_item page-item-51443"><a href="https://theblackwallsttimes.com/op-ed-submissions/">Op-Ed Submissions</a></li>
<li class="page_item page-item-51194"><a href="https://theblackwallsttimes.com/ownership-funding/">Ownership &#038; Funding</a></li>
<li class="page_item page-item-51178"><a href="https://theblackwallsttimes.com/publishing-policies/">Publishing Policies</a></li>
<li class="page_item page-item-45157"><a href="https://theblackwallsttimes.com/team/">TEAM</a></li>
<li class="page_item page-item-41837"><a href="https://theblackwallsttimes.com/the-victory-of-greenwood-series/">The Victory of Greenwood Series</a></li>
			</ul>

			</aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-10 last">
						<aside id="penci_related_news_widget-4" class="widget penci_related_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Related Post</span></h4>					<ul id="penci-relatedwg-2235" class="side-newsfeed">
													<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/09/Hannah-Jones-e1631900709731.jpeg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/" title="Nikole Hannah-Jones’ warning on democracy in AP interview"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2021/12/18/nikole-hannah-jones-warning-on-democracy-in-ap-interview/" rel="bookmark" title="Nikole Hannah-Jones’ warning on democracy in AP interview">
												Nikole Hannah-Jones’ warning on democracy in AP interview											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2021-12-18T12:37:46-05:00">December 18, 2021</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/Warnock.jpg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/18/proud-boys-supporter-gets-33-months-in-prison-for-threatening-sen-raphael-warnock/" title="Proud Boys&#8217; supporter gets 33 months in prison for threatening Sen. Raphael Warnock"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2021/12/18/proud-boys-supporter-gets-33-months-in-prison-for-threatening-sen-raphael-warnock/" rel="bookmark" title="Proud Boys&#8217; supporter gets 33 months in prison for threatening Sen. Raphael Warnock">
												Proud Boys&#8217; supporter gets 33 months in prison for threatening Sen. Raphael Warnock											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2021-12-18T12:11:20-05:00">December 18, 2021</time></span>
																			</div>
								</div>
							</li>
														<li class="penci-feed">
								<div class="side-item">

																			<div class="side-image">
																																		<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/theblackwallsttimes.com/wp-content/uploads/2021/12/1.jpg?resize=263%2C175&#038;ssl=1');" href="https://theblackwallsttimes.com/2021/12/17/keechant-sewell-to-become-first-female-nypd-chief-of-police-in-city-history/" title="Keechant Sewell to become first female NYPD chief of police in city history"></a>
											
																					</div>
																		<div class="side-item-text">
										<h4 class="side-title-post">
											<a href="https://theblackwallsttimes.com/2021/12/17/keechant-sewell-to-become-first-female-nypd-chief-of-police-in-city-history/" rel="bookmark" title="Keechant Sewell to become first female NYPD chief of police in city history">
												Keechant Sewell to become first female NYPD chief of police in city history											</a>
										</h4>
																					<span class="side-item-meta"><time class="entry-date published" datetime="2021-12-17T19:00:03-05:00">December 17, 2021</time></span>
																			</div>
								</div>
							</li>
												</ul>

				</aside>					</div>
							</div>
		</div>


	<div class="footer-subscribe">
			</div>

<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
	<div class="container">
					<div class="footer-socials-section">
				<ul class="footer-socials">
											<li><a href="https://www.facebook.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-facebook" ></i><span>Facebook</span></a></li>
																<li><a href="https://twitter.com/TheBWSTimes"  target="_blank"><i class="penci-faicon fa fa-twitter" ></i><span>Twitter</span></a></li>
																<li><a href="https://www.instagram.com/thebwstimes/"  target="_blank"><i class="penci-faicon fa fa-instagram" ></i><span>Instagram</span></a></li>
																<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-pinterest" ></i><span>Pinterest</span></a></li>
																<li><a href="https://www.linkedin.com/company/bwstimes"  target="_blank"><i class="penci-faicon fa fa-linkedin" ></i><span>Linkedin</span></a></li>
																															<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i><span>Youtube</span></a></li>
																																																																																																																																																																	<li><a href="https://theblackwallsttimes.com/"  target="_blank"><i class="penci-icon-tiktok"><svg aria-hidden="true" data-prefix="fab" data-icon="tiktok" class="penci-svg-tiktok" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M448,209.91a210.06,210.06,0,0,1-122.77-39.25V349.38A162.55,162.55,0,1,1,185,188.31V278.2a74.62,74.62,0,1,0,52.23,71.18V0l88,0a121.18,121.18,0,0,0,1.86,22.17h0A122.18,122.18,0,0,0,381,102.39a121.43,121.43,0,0,0,67,20.14Z" class=""></path></svg></i><span>tiktok</span></a></li>
									</ul>
			</div>
											<div class="penci-go-to-top-floating"><i class="penci-faicon fa fa-angle-up" ></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>
<div
				class="hustle-ui hustle-popup hustle-palette--gray_slate hustle_module_id_8 module_id_8  "
				
			data-id="8"
			data-render-id="0"
			data-tracking="disabled"
			
				data-intro="no_animation"
				data-outro="no_animation"
				data-overlay-close="1"
				data-close-delay="false"
				
				style="opacity: 0;"
			><div class="hustle-popup-mask hustle-optin-mask" aria-hidden="true"></div><div class="hustle-popup-content"><div class="hustle-optin hustle-optin--default"><button class="hustle-button-icon hustle-button-close has-background">
			<span class="hustle-icon-close" aria-hidden="true"></span>
			<span class="hustle-screen-reader">Close this module</span>
		</button><div class="hustle-success" data-close-delay="false" style="display: none;"><span class="hustle-icon-check" aria-hidden="true"></span><div class="hustle-success-content"></div></div><div class="hustle-layout"><div class="hustle-layout-body"><div class="hustle-layout-content hustle-layout-position--above"><div class="hustle-image hustle-image-fit--contain" aria-hidden="true"><img src="https://theblackwallsttimes.com/wp-content/uploads/2020/12/BWSTimes-Bubble-Logo-.png" alt="" class="hustle-image-position--centercenter" /></div><div class="hustle-content"><div class="hustle-content-wrap"><div class="hustle-group-title"><span class="hustle-title">THE BLACK WALL STREET TIMES</span></div><div class="hustle-group-content"><p style="text-align: center">Support Black-owned media, learn our stories and diverse perspectives by subscribing below.</p></div></div></div></div><form class="hustle-layout-form" novalidate="novalidate"><div class="hustle-form hustle-form-inline"><div class="hustle-form-fields hustle-proximity-separated"><div class="hustle-field hustle-field-required "><label for="hustle-field-email-module-8" id="hustle-field-email-module-8-label" class="hustle-screen-reader">Email</label><input id="hustle-field-email-module-8" type="email" class="hustle-input " name="email" value="" aria-labelledby="hustle-field-email-module-8-label" data-validate="1" data-required-error="Email field is required." data-validation-error="Please enter a valid email." /><span class="hustle-input-label" aria-hidden="true" style="flex-flow: row nowrap;"><span>Enter your email address</span></span></div><button class="hustle-button hustle-button-submit " aria-live="polite" data-loading-text="Form is being submitted, please wait a bit."><span class="hustle-button-text">Subscribe</span><span class="hustle-icon-loader hustle-loading-icon" aria-hidden="true"></span></button></div></div><input type="hidden" name="hustle_module_id" value="8"><input type="hidden" name="post_id" value="56844"><div class="hustle-error-message" style="display: none;" data-default-error="Something went wrong, please try again."></div></form></div></div></div></div></div><!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202150'></script>
	<div style="display:none">
	<div class="grofile-hash-map-a7f34fb96ded4145cdee142e464d579b">
	</div>
	</div>
    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<link rel='stylesheet' id='all-css-767f1cada21182c5310a3012f7cd588f' href='https://theblackwallsttimes.com/_static/??-eJytzF0KgzAQBOALNVnE1p+H0rNEGzQQs4uzIdc3CPYC9XGGma+ImTmpT0oS8xISqPD+ld0DRliykAO8gtYMjd7kQDN+KdQz7BaSreWj/IctkScX79JYtEI3Yefiwj7bu+na1/jshr49AK1het0=' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='hustle-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A700%2Cregular%2C500%2C400&#038;display=swap' media='all' />
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/theblackwallsttimes.com","is_cart":"","cart_redirect_after_add":"no"};
</script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJydTs1OwzAMfqGlhk2aymHizANwnlLHMLdNnMUu1d6e0Q0NMdoDJ3+2v78xO5RklAxyP7xzUmjJsscO9pwQmoH7APkgJuk6qsipanU13ktRml6wUwisBu3t4Hzi6I1lTpkpIbtCH0zjl7A9DlROFXk9ZSY8+GILub/VFzRDHkVQYqSCBF6VTG+Bbqo78Hf+tL6+LET/7fZWJloAH4Izcbjcf6aSnonSMZ1RdUH/L/LjfTV5jrvH7aaun7brh/oTtojGGQ=='></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_4c7e640bcf22e7b48d69c5ce2fc2a0fb","fragment_name":"wc_fragments_4c7e640bcf22e7b48d69c5ce2fc2a0fb","request_timeout":"5000"};
</script>
<script src='https://theblackwallsttimes.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js' id='wc-cart-fragments-js'></script>
<script id='wc-cart-fragments-js-after'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
		
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-includes/js/jquery/ui/core.min.js?m=1616089703'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script>
<script id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/js/hustle-ui.min.js?m=1635946873'></script>
<script src='https://theblackwallsttimes.com/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script id='hustle_front-js-extra'>
var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"0","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["scroll"]},"animation_in":"no_animation","animation_out":"no_animation","after_close":"no_show_all","expiration":365,"expiration_unit":"days","on_submit":"close","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"no_show_all","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"10\/23\/2021","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"10\/29\/2021","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"allow_scroll_page":"0","close_on_background_click":"1","auto_hide":"0","auto_hide_unit":"seconds","auto_hide_time":"5","after_close_trigger":["click_close_icon"]},"module_id":"8","blog_id":"0","module_name":"The Weekly | The Black Wall Street Times","module_type":"popup","active":"1","module_mode":"optin"}];
var incOpt = {"is_admin":"","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god&text=VP%20Kamala%20Harris%20Checks%20Charlamagne%20Tha%20God","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god","email":"mailto:?subject=VP%20Kamala%20Harris%20Checks%20Charlamagne%20Tha%20God&body=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god"},"ajaxurl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","page_id":"56844","page_slug":"2021-12-18-vp-kamala-harris-checks-charlamagne-tha-god","is_upfront":"","script_delay":"3000"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/wp-content/plugins/wordpress-popup/assets/js/front.min.js?m=1635946873'></script>
<script src='https://secure.gravatar.com/js/gprofiles.js' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script id='main-scripts-js-extra'>
var ajax_var_more = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"97d80222fc","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_like_post-js-extra'>
var ajax_var = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"97d80222fc","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='penci_ajax_archive_more_scroll-js-extra'>
var SOLEDADLOCALIZE = {"url":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"97d80222fc","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
</script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='penci_rateyo-js-extra'>
var PENCI = {"ajaxUrl":"https:\/\/theblackwallsttimes.com\/wp-admin\/admin-ajax.php","nonce":"97d80222fc"};
</script>
<script type='text/javascript'  src='https://theblackwallsttimes.com/_static/??-eJytUdtuwyAM/aFRtlWr1Idpn1IRsBKngJnttMq+fqCm2q1r97AnsM+FY3MsxlNWyGpLnHrMYkfQ4vzeJgpTBLHH0jMNtBrl7vjB1gFSBYUiBBfsKDZiJ0Y8Y9FVwnyTn9wfSIVETcQ93GQ69gMewCRiME22KDD7OIXKrRxPKVW1YShxvhDyvAKI0HjEpjBZJwIqtg1oK6quOhTXw5fiituPhWLom6FAy9xynW7mBNxwWc7dAXIgtm5SSk4V/Rkx0b3NBlMNJTagaM2pwAJekbKhToAPwP//zKfGL+YFsse6fY8F2tzj6wQ8r9gpzHRlg991VYC5350aF/65lpA6CIvlS3p+2Ky3T/fb7ebxHX6iHss='></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=56844&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=4204ac9bbcbcfbb3b0f878fd9cf7e3f0346a7f6f#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=124418680&postid=56844&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=4204ac9bbcbcfbb3b0f878fd9cf7e3f0346a7f6f#parent=https%3A%2F%2Ftheblackwallsttimes.com%2F2021%2F12%2F18%2Fvp-kamala-harris-checks-charlamagne-tha-god%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202150.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.5-a.3',blog:'124418680',post:'56844',tz:'-5',srv:'theblackwallsttimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '124418680', '56844' ]);
</script>
<script type="text/javascript">!function(a){"use strict";var b=function(b,c,d){function j(a){if(e.body)return a();setTimeout(function(){j(a)})}function l(){f.addEventListener&&f.removeEventListener("load",l),f.media=d||"all"}var g,e=a.document,f=e.createElement("link");if(c)g=c;else{var h=(e.body||e.getElementsByTagName("head")[0]).childNodes;g=h[h.length-1]}var i=e.styleSheets;f.rel="stylesheet",f.href=b,f.media="only x",j(function(){g.parentNode.insertBefore(f,c?g:g.nextSibling)});var k=function(a){for(var b=f.href,c=i.length;c--;)if(i[c].href===b)return a();setTimeout(function(){k(a)})};return f.addEventListener&&f.addEventListener("load",l),f.onloadcssdefined=k,k(l),f};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this); !function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(a){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script>
	<style type="text/css" id="hustle-module-8-0-styles" class="hustle-module-styles hustle-module-styles-8">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</style>

<amp-ad width=728 height=90 type="adbutler" data-account="181918" data-zone=""> </amp-ad>

</body>
</html>
<!--
	generated in 1.060 seconds
	214686 bytes batcached for 300 seconds
-->
